summaryrefslogtreecommitdiffstats
path: root/vendor/topological-sort/README.md
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /vendor/topological-sort/README.md
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/topological-sort/README.md')
-rw-r--r--vendor/topological-sort/README.md40
1 files changed, 40 insertions, 0 deletions
diff --git a/vendor/topological-sort/README.md b/vendor/topological-sort/README.md
new file mode 100644
index 000000000..87dd7bea5
--- /dev/null
+++ b/vendor/topological-sort/README.md
@@ -0,0 +1,40 @@
+# topological-sort-rs
+
+[![Build Status](https://travis-ci.org/gifnksm/topological-sort-rs.svg)](https://travis-ci.org/gifnksm/topological-sort-rs)
+[![Coverage Status](https://coveralls.io/repos/gifnksm/topological-sort-rs/badge.svg?branch=master&service=github)](https://coveralls.io/github/gifnksm/topological-sort-rs?branch=master)
+[![crates.io](http://meritbadge.herokuapp.com/topological-sort)](https://crates.io/crates/topological-sort)
+
+Performs topological sorting.
+
+[Documentation](https://docs.rs/topological-sort/~0.0)
+
+## How to use?
+
+Add this to your `Cargo.toml`:
+
+```toml
+[dependencies]
+topological-sort = "0.0"
+```
+
+and this to your crate root:
+
+```rust
+extern crate topological_sort;
+```
+
+## License
+
+Licensed under either of
+
+ * Apache License, Version 2.0, ([LICENSE-APACHE](LICENSE-APACHE) or http://www.apache.org/licenses/LICENSE-2.0)
+ * MIT license ([LICENSE-MIT](LICENSE-MIT) or http://opensource.org/licenses/MIT)
+
+at your option.
+
+### Contribution
+
+Unless you explicitly state otherwise, any contribution intentionally
+submitted for inclusion in the work by you, as defined in the Apache-2.0
+license, shall be dual licensed as above, without any additional terms or
+conditions.