summaryrefslogtreecommitdiffstats
path: root/vendor/tracing-attributes/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /vendor/tracing-attributes/Cargo.toml
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/tracing-attributes/Cargo.toml')
-rw-r--r--vendor/tracing-attributes/Cargo.toml85
1 files changed, 85 insertions, 0 deletions
diff --git a/vendor/tracing-attributes/Cargo.toml b/vendor/tracing-attributes/Cargo.toml
new file mode 100644
index 000000000..3ecaba6fc
--- /dev/null
+++ b/vendor/tracing-attributes/Cargo.toml
@@ -0,0 +1,85 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.49.0"
+name = "tracing-attributes"
+version = "0.1.22"
+authors = [
+ "Tokio Contributors <team@tokio.rs>",
+ "Eliza Weisman <eliza@buoyant.io>",
+ "David Barsky <dbarsky@amazon.com>",
+]
+description = """
+Procedural macro attributes for automatically instrumenting functions.
+"""
+homepage = "https://tokio.rs"
+readme = "README.md"
+keywords = [
+ "logging",
+ "tracing",
+ "macro",
+ "instrument",
+ "log",
+]
+categories = [
+ "development-tools::debugging",
+ "development-tools::profiling",
+ "asynchronous",
+]
+license = "MIT"
+repository = "https://github.com/tokio-rs/tracing"
+
+[lib]
+proc-macro = true
+
+[dependencies.proc-macro2]
+version = "1"
+
+[dependencies.quote]
+version = "1"
+
+[dependencies.syn]
+version = "1.0.43"
+features = [
+ "full",
+ "parsing",
+ "printing",
+ "visit",
+ "visit-mut",
+ "clone-impls",
+ "extra-traits",
+ "proc-macro",
+]
+default-features = false
+
+[dev-dependencies.async-trait]
+version = "0.1.44"
+
+[dev-dependencies.tokio-test]
+version = "0.3.0"
+
+[dev-dependencies.tracing]
+version = "0.1"
+
+[dev-dependencies.tracing-core]
+version = "0.1"
+
+[dev-dependencies.tracing-subscriber]
+version = "0.3"
+features = ["env-filter"]
+
+[features]
+async-await = []
+
+[badges.maintenance]
+status = "experimental"