summaryrefslogtreecommitdiffstats
path: root/vendor/tracing-tree/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /vendor/tracing-tree/Cargo.toml
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/tracing-tree/Cargo.toml')
-rw-r--r--vendor/tracing-tree/Cargo.toml64
1 files changed, 64 insertions, 0 deletions
diff --git a/vendor/tracing-tree/Cargo.toml b/vendor/tracing-tree/Cargo.toml
new file mode 100644
index 000000000..32c47092f
--- /dev/null
+++ b/vendor/tracing-tree/Cargo.toml
@@ -0,0 +1,64 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "tracing-tree"
+version = "0.2.1"
+authors = [
+ "David Barsky <me@davidbarsky.com>",
+ "Nathan Whitaker",
+]
+description = "A Tracing Layer which prints a tree of spans and events."
+readme = "README.md"
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/davidbarsky/tracing-tree"
+
+[[test]]
+name = "ui"
+harness = false
+
+[dependencies.ansi_term]
+version = "0.12"
+
+[dependencies.atty]
+version = "0.2"
+
+[dependencies.tracing-core]
+version = "0.1"
+
+[dependencies.tracing-log]
+version = "0.1"
+optional = true
+
+[dependencies.tracing-subscriber]
+version = "0.3"
+features = [
+ "registry",
+ "fmt",
+ "std",
+]
+default-features = false
+
+[dev-dependencies.assert_cmd]
+version = "1"
+
+[dev-dependencies.glob]
+version = "0.3"
+
+[dev-dependencies.log]
+version = "0.4"
+
+[dev-dependencies.tracing]
+version = "0.1"
+
+[features]
+default = ["tracing-log"]