summaryrefslogtreecommitdiffstats
path: root/vendor/unic-common
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /vendor/unic-common
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/unic-common')
-rw-r--r--vendor/unic-common/.cargo-checksum.json1
-rw-r--r--vendor/unic-common/Cargo.toml44
-rw-r--r--vendor/unic-common/README.md7
-rw-r--r--vendor/unic-common/src/lib.rs31
-rw-r--r--vendor/unic-common/src/pkg_info.rs20
-rw-r--r--vendor/unic-common/src/version.rs72
6 files changed, 175 insertions, 0 deletions
diff --git a/vendor/unic-common/.cargo-checksum.json b/vendor/unic-common/.cargo-checksum.json
new file mode 100644
index 000000000..c218ae248
--- /dev/null
+++ b/vendor/unic-common/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{"Cargo.toml":"719fc6cbaa72559247169192a041fc1c4dfcec442987b204a7237e22836bbb14","README.md":"54c3f5551f27720e50315ba3ed76b2bf47db4692de1e6bdc12434022971b5ee3","src/lib.rs":"726d922245ebdf3bc474d48edf032b9af7fe24fc79ee17d87e2d295103e39ea0","src/pkg_info.rs":"37cbe4efd0b0205d251e1ef7714b23e3be27052c8a0de6b1ae3cbf3aefae1fe5","src/version.rs":"ee5f50444acc2df5f9cd4ec97bd81444c6425b55fd37327c254ccd1736270898"},"package":"80d7ff825a6a654ee85a63e80f92f054f904f21e7d12da4e22f9834a4aaa35bc"} \ No newline at end of file
diff --git a/vendor/unic-common/Cargo.toml b/vendor/unic-common/Cargo.toml
new file mode 100644
index 000000000..41f1abd74
--- /dev/null
+++ b/vendor/unic-common/Cargo.toml
@@ -0,0 +1,44 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g. crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "unic-common"
+version = "0.9.0"
+authors = ["The UNIC Project Developers"]
+exclude = []
+description = "UNIC — Common Utilities"
+keywords = ["unicode", "version"]
+categories = ["internationalization", "text-processing"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/open-i18n/rust-unic/"
+
+[features]
+default = []
+unstable = []
+[badges.appveyor]
+branch = "master"
+repository = "open-i18n/rust-unic"
+service = "github"
+
+[badges.is-it-maintained-issue-resolution]
+repository = "open-i18n/rust-unic"
+
+[badges.is-it-maintained-open-issues]
+repository = "open-i18n/rust-unic"
+
+[badges.maintenance]
+status = "actively-developed"
+
+[badges.travis-ci]
+branch = "master"
+repository = "open-i18n/rust-unic"
diff --git a/vendor/unic-common/README.md b/vendor/unic-common/README.md
new file mode 100644
index 000000000..9d86d2291
--- /dev/null
+++ b/vendor/unic-common/README.md
@@ -0,0 +1,7 @@
+# UNIC — Common Utilities
+
+[![Crates.io](https://img.shields.io/crates/v/unic-common.svg)](https://crates.io/crates/unic-common)
+[![Documentation](https://docs.rs/unic-common/badge.svg)](https://docs.rs/unic-common/)
+
+This UNIC component provides common types, algorithms and macros not shared
+between many components.
diff --git a/vendor/unic-common/src/lib.rs b/vendor/unic-common/src/lib.rs
new file mode 100644
index 000000000..0ce4f213e
--- /dev/null
+++ b/vendor/unic-common/src/lib.rs
@@ -0,0 +1,31 @@
+// Copyright 2017 The UNIC Project Developers.
+//
+// See the COPYRIGHT file at the top-level directory of this distribution.
+//
+// Licensed under the Apache License, Version 2.0 <LICENSE-APACHE or
+// http://www.apache.org/licenses/LICENSE-2.0> or the MIT license
+// <LICENSE-MIT or http://opensource.org/licenses/MIT>, at your
+// option. This file may not be copied, modified, or distributed
+// except according to those terms.
+
+#![no_std]
+#![warn(
+ bad_style,
+ missing_debug_implementations,
+ missing_docs,
+ unconditional_recursion
+)]
+#![forbid(unsafe_code)]
+#![cfg_attr(feature = "unstable", feature(unicode_version))]
+
+//! # UNIC — Common Utilities
+//!
+//! A component of [`unic`: Unicode and Internationalization Crates for Rust](/unic/).
+//!
+//! This UNIC component provides common types, algorithms and macros not shared between many
+//! components.
+
+mod pkg_info;
+pub use crate::pkg_info::{PKG_DESCRIPTION, PKG_NAME, PKG_VERSION};
+
+pub mod version;
diff --git a/vendor/unic-common/src/pkg_info.rs b/vendor/unic-common/src/pkg_info.rs
new file mode 100644
index 000000000..a1ab2853f
--- /dev/null
+++ b/vendor/unic-common/src/pkg_info.rs
@@ -0,0 +1,20 @@
+// Copyright 2017 The UNIC Project Developers.
+//
+// See the COPYRIGHT file at the top-level directory of this distribution.
+//
+// Licensed under the Apache License, Version 2.0 <LICENSE-APACHE or
+// http://www.apache.org/licenses/LICENSE-2.0> or the MIT license
+// <LICENSE-MIT or http://opensource.org/licenses/MIT>, at your
+// option. This file may not be copied, modified, or distributed
+// except according to those terms.
+
+//! Package information
+
+/// UNIC component version.
+pub const PKG_VERSION: &str = env!("CARGO_PKG_VERSION");
+
+/// UNIC component name.
+pub const PKG_NAME: &str = env!("CARGO_PKG_NAME");
+
+/// UNIC component description.
+pub const PKG_DESCRIPTION: &str = env!("CARGO_PKG_DESCRIPTION");
diff --git a/vendor/unic-common/src/version.rs b/vendor/unic-common/src/version.rs
new file mode 100644
index 000000000..6faf7def0
--- /dev/null
+++ b/vendor/unic-common/src/version.rs
@@ -0,0 +1,72 @@
+// Copyright 2017 The UNIC Project Developers.
+//
+// See the COPYRIGHT file at the top-level directory of this distribution.
+//
+// Licensed under the Apache License, Version 2.0 <LICENSE-APACHE or
+// http://www.apache.org/licenses/LICENSE-2.0> or the MIT license
+// <LICENSE-MIT or http://opensource.org/licenses/MIT>, at your
+// option. This file may not be copied, modified, or distributed
+// except according to those terms.
+
+//! *Version* data types.
+
+use core::fmt;
+
+#[cfg(feature = "unstable")]
+use core::char;
+
+/// Represents a *Unicode Version* type.
+///
+/// UNIC's *Unicode Version* type is used for Unicode datasets and specifications, including The
+/// Unicode Standard (TUS), Unicode Character Database (UCD), Common Local Data Repository (CLDR),
+/// IDNA, Emoji, etc.
+///
+/// TODO: *Unicode Version* is guaranteed to have three integer fields between 0 and 255. We are
+/// going to switch over to `u8` after Unicode 11.0.0 release.
+///
+/// Refs:
+/// - <https://www.unicode.org/versions/>
+/// - <https://www.unicode.org/L2/L2017/17222.htm#152-C3>
+#[derive(Clone, Copy, Eq, PartialEq, Ord, PartialOrd, Debug, Hash, Default)]
+pub struct UnicodeVersion {
+ /// Major version.
+ pub major: u16,
+
+ /// Minor version.
+ pub minor: u16,
+
+ /// Micro (or Update) version.
+ pub micro: u16,
+}
+
+impl fmt::Display for UnicodeVersion {
+ fn fmt(&self, f: &mut fmt::Formatter<'_>) -> fmt::Result {
+ write!(f, "{}.{}.{}", self.major, self.minor, self.micro)
+ }
+}
+
+#[cfg(feature = "unstable")]
+/// Convert from Rust's internal Unicode Version.
+impl From<char::UnicodeVersion> for UnicodeVersion {
+ fn from(value: char::UnicodeVersion) -> UnicodeVersion {
+ UnicodeVersion {
+ major: value.major as u16,
+ minor: value.minor as u16,
+ micro: value.micro as u16,
+ }
+ }
+}
+
+#[cfg(test)]
+mod tests {
+ #[cfg(feature = "unstable")]
+ #[test]
+ fn test_against_rust_internal() {
+ use core::char;
+
+ use super::UnicodeVersion;
+
+ let core_unicode_version: UnicodeVersion = char::UNICODE_VERSION.into();
+ assert!(core_unicode_version.major >= 10);
+ }
+}