summaryrefslogtreecommitdiffstats
path: root/vendor/unic-langid-impl/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /vendor/unic-langid-impl/Cargo.toml
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/unic-langid-impl/Cargo.toml')
-rw-r--r--vendor/unic-langid-impl/Cargo.toml76
1 files changed, 76 insertions, 0 deletions
diff --git a/vendor/unic-langid-impl/Cargo.toml b/vendor/unic-langid-impl/Cargo.toml
new file mode 100644
index 000000000..6431f4c58
--- /dev/null
+++ b/vendor/unic-langid-impl/Cargo.toml
@@ -0,0 +1,76 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "unic-langid-impl"
+version = "0.9.0"
+authors = ["Zibi Braniecki <gandalf@mozilla.com>"]
+include = ["src/**/*", "benches/*.rs", "Cargo.toml", "README.md"]
+description = "API for managing Unicode Language Identifiers"
+readme = "README.md"
+categories = ["internationalization"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/zbraniecki/unic-locale"
+
+[[bin]]
+name = "generate_likelysubtags"
+required-features = ["binary"]
+
+[[bin]]
+name = "generate_layout"
+required-features = ["binary"]
+
+[[test]]
+name = "likelysubtags"
+path = "tests/likelysubtags.rs"
+required-features = ["likelysubtags"]
+
+[[bench]]
+name = "parser"
+harness = false
+
+[[bench]]
+name = "langid"
+harness = false
+
+[[bench]]
+name = "canonicalize"
+harness = false
+
+[[bench]]
+name = "likely_subtags"
+harness = false
+required-features = ["likelysubtags"]
+[dependencies.serde]
+version = "1.0"
+optional = true
+
+[dependencies.serde_json]
+version = "1.0"
+optional = true
+
+[dependencies.tinystr]
+version = "0.3.2"
+[dev-dependencies.criterion]
+version = "0.3"
+
+[dev-dependencies.serde]
+version = "1.0"
+features = ["derive"]
+
+[dev-dependencies.serde_json]
+version = "1.0"
+
+[features]
+binary = ["serde", "serde_json"]
+likelysubtags = []