summaryrefslogtreecommitdiffstats
path: root/vendor/unified-diff/README.md
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /vendor/unified-diff/README.md
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/unified-diff/README.md')
-rw-r--r--vendor/unified-diff/README.md41
1 files changed, 41 insertions, 0 deletions
diff --git a/vendor/unified-diff/README.md b/vendor/unified-diff/README.md
new file mode 100644
index 000000000..103c01053
--- /dev/null
+++ b/vendor/unified-diff/README.md
@@ -0,0 +1,41 @@
+A GNU unified diff generator. Oracle tested against GNU patch 2.7.6
+
+Based on the incomplete diff generator in https://github.com/rust-lang/rust/blob/master/src/tools/compiletest/src/runtest.rs,
+but it implements a different format.
+
+```
+~/unified-diff$ cargo run Cargo.lock Cargo.toml
+ Finished dev [unoptimized + debuginfo] target(s) in 0.00s
+ Running `target/debug/unified-diff Cargo.lock Cargo.toml`
+--- Cargo.lock
++++ Cargo.toml
+@@ -1,14 +1,14 @@
+-# This file is automatically @generated by Cargo.
+-# It is not intended for manual editing.
+-[[package]]
+-name = "diff"
+-version = "0.1.12"
+-source = "registry+https://github.com/rust-lang/crates.io-index"
+-checksum = "0e25ea47919b1560c4e3b7fe0aaab9becf5b84a10325ddf7db0f0ba5e1026499"
+-
+-[[package]]
++[package]
+ name = "unified-diff"
+ version = "0.1.0"
+-dependencies = [
+- "diff",
++authors = [
++ "Michael Howell <michael@notriddle.com>",
++ "The Rust Project Developers"
+ ]
++edition = "2018"
++
++[[bin]]
++name = "unified-diff"
++
++[dependencies]
++diff = "0.1.10"
+~/unified-diff$ rustup override set nightly
+~/unified-diff$ cargo fuzz run fuzz_patch
+```
+