summaryrefslogtreecommitdiffstats
path: root/vendor/vcpkg/tests
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:59:24 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:59:24 +0000
commit023939b627b7dc93b01471f7d41fb8553ddb4ffa (patch)
tree60fc59477c605c72b0a1051409062ddecc43f877 /vendor/vcpkg/tests
parentAdding debian version 1.72.1+dfsg1-1. (diff)
downloadrustc-023939b627b7dc93b01471f7d41fb8553ddb4ffa.tar.xz
rustc-023939b627b7dc93b01471f7d41fb8553ddb4ffa.zip
Merging upstream version 1.73.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/vcpkg/tests')
-rw-r--r--vendor/vcpkg/tests/README.md5
-rw-r--r--vendor/vcpkg/tests/run.sh20
-rw-r--r--vendor/vcpkg/tests/vcpkgrs_target.sh22
3 files changed, 0 insertions, 47 deletions
diff --git a/vendor/vcpkg/tests/README.md b/vendor/vcpkg/tests/README.md
deleted file mode 100644
index 56a73b1a3..000000000
--- a/vendor/vcpkg/tests/README.md
+++ /dev/null
@@ -1,5 +0,0 @@
-# individual library tests
-
-These tests should have the same name as the vcpkg port. They are intended to use to verify that building/linking/running is possible on each platform.
-
-The systests are intended to test that the current version of the vcpkg build helper will work with published versions of the most common -sys crates. \ No newline at end of file
diff --git a/vendor/vcpkg/tests/run.sh b/vendor/vcpkg/tests/run.sh
deleted file mode 100644
index b9dcdb369..000000000
--- a/vendor/vcpkg/tests/run.sh
+++ /dev/null
@@ -1,20 +0,0 @@
-#!/bin/bash
-set -ex
-
-SCRIPTDIR="$( cd "$( dirname "${BASH_SOURCE[0]}" )" && pwd )"
-cd $SCRIPTDIR
-
-export VCPKG_ROOT=$SCRIPTDIR/../vcp
-
-source ../setup_vcp.sh
-
-for port in harfbuzz ; do
- # check that the port fails before it is installed
- $VCPKG_ROOT/vcpkg remove $port || true
- cargo clean --manifest-path $port/Cargo.toml
- cargo run --manifest-path $port/Cargo.toml && exit 2
- echo THIS FAILURE IS EXPECTED
- echo This is to ensure that we are not spuriously succeeding because the libraries already exist somewhere on the build machine.
- $VCPKG_ROOT/vcpkg install $port
- cargo run --manifest-path $port/Cargo.toml
-done
diff --git a/vendor/vcpkg/tests/vcpkgrs_target.sh b/vendor/vcpkg/tests/vcpkgrs_target.sh
deleted file mode 100644
index ba46fbf35..000000000
--- a/vendor/vcpkg/tests/vcpkgrs_target.sh
+++ /dev/null
@@ -1,22 +0,0 @@
-#!/bin/bash
-set -ex
-
-SCRIPTDIR="$( cd "$( dirname "${BASH_SOURCE[0]}" )" && pwd )"
-cd $SCRIPTDIR
-
-export VCPKG_ROOT=$SCRIPTDIR/../vcp
-export VCPKGRS_TRIPLET=test-triplet
-export VCPKG_DEFAULT_TRIPLET=test-triplet
-
-cp $VCPKG_ROOT/triplets/x64-linux.cmake $VCPKG_ROOT/triplets/test-triplet.cmake
-for port in harfbuzz ; do
- # check that the port fails before it is installed
- $VCPKG_ROOT/vcpkg remove --no-binarycaching $port || true
- cargo clean --manifest-path $port/Cargo.toml
- cargo run --manifest-path $port/Cargo.toml && exit 2
- echo THIS FAILURE IS EXPECTED
- echo This is to ensure that we are not spuriously succeeding because the libraries already exist somewhere on the build machine.
- # disable binary caching because it breaks this build as of vcpkg 53e6588 (since vcpkg 52a9d9a)
- $VCPKG_ROOT/vcpkg install --no-binarycaching $port
- cargo run --manifest-path $port/Cargo.toml
-done