summaryrefslogtreecommitdiffstats
path: root/vendor/wasi-0.9.0+wasi-snapshot-preview1/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /vendor/wasi-0.9.0+wasi-snapshot-preview1/Cargo.toml
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/wasi-0.9.0+wasi-snapshot-preview1/Cargo.toml')
-rw-r--r--vendor/wasi-0.9.0+wasi-snapshot-preview1/Cargo.toml43
1 files changed, 43 insertions, 0 deletions
diff --git a/vendor/wasi-0.9.0+wasi-snapshot-preview1/Cargo.toml b/vendor/wasi-0.9.0+wasi-snapshot-preview1/Cargo.toml
new file mode 100644
index 000000000..cd0dfb535
--- /dev/null
+++ b/vendor/wasi-0.9.0+wasi-snapshot-preview1/Cargo.toml
@@ -0,0 +1,43 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "wasi"
+version = "0.9.0+wasi-snapshot-preview1"
+authors = ["The Cranelift Project Developers"]
+description = "Experimental WASI API bindings for Rust"
+documentation = "https://docs.rs/wasi"
+readme = "README.md"
+keywords = ["webassembly", "wasm"]
+categories = ["no-std", "wasm"]
+license = "Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT"
+repository = "https://github.com/bytecodealliance/wasi"
+[dependencies.compiler_builtins]
+version = "0.1"
+optional = true
+
+[dependencies.core]
+version = "1.0"
+optional = true
+package = "rustc-std-workspace-core"
+
+[dependencies.rustc-std-workspace-alloc]
+version = "1.0"
+optional = true
+
+[features]
+default = ["std"]
+rustc-dep-of-std = ["compiler_builtins", "core", "rustc-std-workspace-alloc"]
+std = []
+[badges.maintenance]
+status = "experimental"