summaryrefslogtreecommitdiffstats
path: root/vendor/windows_i686_msvc
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /vendor/windows_i686_msvc
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/windows_i686_msvc')
-rw-r--r--vendor/windows_i686_msvc/.cargo-checksum.json1
-rw-r--r--vendor/windows_i686_msvc/Cargo.toml23
-rw-r--r--vendor/windows_i686_msvc/build.rs10
-rw-r--r--vendor/windows_i686_msvc/lib/windows.libbin0 -> 4650454 bytes
-rw-r--r--vendor/windows_i686_msvc/src/lib.rs1
5 files changed, 35 insertions, 0 deletions
diff --git a/vendor/windows_i686_msvc/.cargo-checksum.json b/vendor/windows_i686_msvc/.cargo-checksum.json
new file mode 100644
index 000000000..c2d66824a
--- /dev/null
+++ b/vendor/windows_i686_msvc/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{"Cargo.toml":"0d8170ec4614b8712e38431c6e8bc289a493774ced1c2daf092d9b743aca811a","build.rs":"d5df812ba7add22771644473db37d7de40c1e7479a30f81ae3ccb0d7be3fabe4","lib/windows.lib":"e446677bf0f82af61549ca3aada14326005bfd2f43056212f0ac991b72943661","src/lib.rs":"bdf6c7cf1fc01f69cc1d4e52948d1f246fdd310e6323d5dd1efd23f1daf382ef"},"package":"e2e7917148b2812d1eeafaeb22a97e4813dfa60a3f8f78ebe204bcc88f12f024"} \ No newline at end of file
diff --git a/vendor/windows_i686_msvc/Cargo.toml b/vendor/windows_i686_msvc/Cargo.toml
new file mode 100644
index 000000000..f46bda7db
--- /dev/null
+++ b/vendor/windows_i686_msvc/Cargo.toml
@@ -0,0 +1,23 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "windows_i686_msvc"
+version = "0.36.1"
+authors = ["Microsoft"]
+description = "Code gen support for the windows crate"
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/microsoft/windows-rs"
+
+[package.metadata.docs.rs]
+default-target = "x86_64-pc-windows-msvc"
+targets = []
diff --git a/vendor/windows_i686_msvc/build.rs b/vendor/windows_i686_msvc/build.rs
new file mode 100644
index 000000000..53892bff6
--- /dev/null
+++ b/vendor/windows_i686_msvc/build.rs
@@ -0,0 +1,10 @@
+fn main() {
+ let target = std::env::var("TARGET").unwrap();
+ if target != "i686-pc-windows-msvc" && target != "i686-uwp-windows-msvc" {
+ return;
+ }
+
+ let dir = std::env::var("CARGO_MANIFEST_DIR").unwrap();
+
+ println!("cargo:rustc-link-search=native={}", std::path::Path::new(&dir).join("lib").display());
+}
diff --git a/vendor/windows_i686_msvc/lib/windows.lib b/vendor/windows_i686_msvc/lib/windows.lib
new file mode 100644
index 000000000..cc96530b3
--- /dev/null
+++ b/vendor/windows_i686_msvc/lib/windows.lib
Binary files differ
diff --git a/vendor/windows_i686_msvc/src/lib.rs b/vendor/windows_i686_msvc/src/lib.rs
new file mode 100644
index 000000000..0c9ac1ac8
--- /dev/null
+++ b/vendor/windows_i686_msvc/src/lib.rs
@@ -0,0 +1 @@
+#![no_std]