summaryrefslogtreecommitdiffstats
path: root/vendor/windows_x86_64_msvc
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /vendor/windows_x86_64_msvc
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/windows_x86_64_msvc')
-rw-r--r--vendor/windows_x86_64_msvc/.cargo-checksum.json1
-rw-r--r--vendor/windows_x86_64_msvc/Cargo.toml23
-rw-r--r--vendor/windows_x86_64_msvc/build.rs10
-rw-r--r--vendor/windows_x86_64_msvc/lib/windows.libbin0 -> 4345164 bytes
-rw-r--r--vendor/windows_x86_64_msvc/src/lib.rs1
5 files changed, 35 insertions, 0 deletions
diff --git a/vendor/windows_x86_64_msvc/.cargo-checksum.json b/vendor/windows_x86_64_msvc/.cargo-checksum.json
new file mode 100644
index 000000000..99097526d
--- /dev/null
+++ b/vendor/windows_x86_64_msvc/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{"Cargo.toml":"a1ffbe2c20bb23e941294ac12ec4b7648e7e38a1783590a530606fc06256fbd1","build.rs":"c801bf00de0978fd5252930993878c0b0eed65336c82c89289efaf9a9ad5ac22","lib/windows.lib":"6c6d7c46201dde65bda21e1beb307c40a3172933c01578ec08e99278ad0449b8","src/lib.rs":"bdf6c7cf1fc01f69cc1d4e52948d1f246fdd310e6323d5dd1efd23f1daf382ef"},"package":"c811ca4a8c853ef420abd8592ba53ddbbac90410fab6903b3e79972a631f7680"} \ No newline at end of file
diff --git a/vendor/windows_x86_64_msvc/Cargo.toml b/vendor/windows_x86_64_msvc/Cargo.toml
new file mode 100644
index 000000000..fa1fc4e57
--- /dev/null
+++ b/vendor/windows_x86_64_msvc/Cargo.toml
@@ -0,0 +1,23 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "windows_x86_64_msvc"
+version = "0.36.1"
+authors = ["Microsoft"]
+description = "Code gen support for the windows crate"
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/microsoft/windows-rs"
+
+[package.metadata.docs.rs]
+default-target = "x86_64-pc-windows-msvc"
+targets = []
diff --git a/vendor/windows_x86_64_msvc/build.rs b/vendor/windows_x86_64_msvc/build.rs
new file mode 100644
index 000000000..c51c8caa8
--- /dev/null
+++ b/vendor/windows_x86_64_msvc/build.rs
@@ -0,0 +1,10 @@
+fn main() {
+ let target = std::env::var("TARGET").unwrap();
+ if target != "x86_64-pc-windows-msvc" && target != "x86_64-uwp-windows-msvc" {
+ return;
+ }
+
+ let dir = std::env::var("CARGO_MANIFEST_DIR").unwrap();
+
+ println!("cargo:rustc-link-search=native={}", std::path::Path::new(&dir).join("lib").display());
+}
diff --git a/vendor/windows_x86_64_msvc/lib/windows.lib b/vendor/windows_x86_64_msvc/lib/windows.lib
new file mode 100644
index 000000000..4d1333c7d
--- /dev/null
+++ b/vendor/windows_x86_64_msvc/lib/windows.lib
Binary files differ
diff --git a/vendor/windows_x86_64_msvc/src/lib.rs b/vendor/windows_x86_64_msvc/src/lib.rs
new file mode 100644
index 000000000..0c9ac1ac8
--- /dev/null
+++ b/vendor/windows_x86_64_msvc/src/lib.rs
@@ -0,0 +1 @@
+#![no_std]