summaryrefslogtreecommitdiffstats
path: root/vendor/xshell/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /vendor/xshell/Cargo.toml
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/xshell/Cargo.toml')
-rw-r--r--vendor/xshell/Cargo.toml27
1 files changed, 27 insertions, 0 deletions
diff --git a/vendor/xshell/Cargo.toml b/vendor/xshell/Cargo.toml
new file mode 100644
index 000000000..f4fb7cff2
--- /dev/null
+++ b/vendor/xshell/Cargo.toml
@@ -0,0 +1,27 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.59"
+name = "xshell"
+version = "0.2.2"
+authors = ["Aleksey Kladov <aleksey.kladov@gmail.com>"]
+exclude = [".github/", "bors.toml", "rustfmt.toml", "cbench", "mock_bin/"]
+description = "Utilities for quick shell scripting in Rust"
+categories = ["development-tools::build-utils", "filesystem"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/matklad/xshell"
+resolver = "2"
+[dependencies.xshell-macros]
+version = "=0.2.2"
+[dev-dependencies.anyhow]
+version = "1.0.56"