summaryrefslogtreecommitdiffstats
path: root/vendor/zerofrom-derive/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-07 05:48:42 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-07 05:48:42 +0000
commitcec1877e180393eba0f6ddb0cf97bf3a791631c7 (patch)
tree47b4dac2a9dd9a40c30c251b4d4a72d7ccf77e9f /vendor/zerofrom-derive/Cargo.toml
parentAdding debian version 1.74.1+dfsg1-1. (diff)
downloadrustc-cec1877e180393eba0f6ddb0cf97bf3a791631c7.tar.xz
rustc-cec1877e180393eba0f6ddb0cf97bf3a791631c7.zip
Merging upstream version 1.75.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/zerofrom-derive/Cargo.toml')
-rw-r--r--vendor/zerofrom-derive/Cargo.toml19
1 files changed, 14 insertions, 5 deletions
diff --git a/vendor/zerofrom-derive/Cargo.toml b/vendor/zerofrom-derive/Cargo.toml
index 66a5e8d94..46e1a26c3 100644
--- a/vendor/zerofrom-derive/Cargo.toml
+++ b/vendor/zerofrom-derive/Cargo.toml
@@ -12,7 +12,7 @@
[package]
edition = "2021"
name = "zerofrom-derive"
-version = "0.1.2"
+version = "0.1.3"
authors = ["Manish Goregaokar <manishsmail@gmail.com>"]
description = "Custom derive for the zerofrom crate"
readme = "README.md"
@@ -28,7 +28,7 @@ categories = [
"caching",
"no-std",
]
-license = "Unicode-DFS-2016"
+license-file = "LICENSE"
repository = "https://github.com/unicode-org/icu4x"
[package.metadata.workspaces]
@@ -45,13 +45,22 @@ version = "1.0.27"
version = "1.0.9"
[dependencies.syn]
-version = "1.0.73"
+version = "2"
features = [
"derive",
"fold",
+ "visit",
]
[dependencies.synstructure]
-version = "0.12.4"
+version = "0.13"
-[dev-dependencies]
+[dev-dependencies.zerofrom]
+version = "0.1.1"
+features = ["derive"]
+default-features = false
+
+[dev-dependencies.zerovec]
+version = "0.9.4"
+features = ["yoke"]
+default-features = false