summaryrefslogtreecommitdiffstats
path: root/compiler/rustc_abi/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'compiler/rustc_abi/Cargo.toml')
-rw-r--r--compiler/rustc_abi/Cargo.toml10
1 files changed, 8 insertions, 2 deletions
diff --git a/compiler/rustc_abi/Cargo.toml b/compiler/rustc_abi/Cargo.toml
index 48b199cb8..e549724b1 100644
--- a/compiler/rustc_abi/Cargo.toml
+++ b/compiler/rustc_abi/Cargo.toml
@@ -4,21 +4,27 @@ version = "0.0.0"
edition = "2021"
[dependencies]
+# tidy-alphabetical-start
bitflags = "1.2.1"
-tracing = "0.1"
rand = { version = "0.8.4", default-features = false, optional = true }
rand_xoshiro = { version = "0.6.0", optional = true }
rustc_data_structures = { path = "../rustc_data_structures", optional = true }
rustc_index = { path = "../rustc_index", default-features = false }
rustc_macros = { path = "../rustc_macros", optional = true }
rustc_serialize = { path = "../rustc_serialize", optional = true }
+tracing = "0.1"
+# tidy-alphabetical-end
[features]
+# tidy-alphabetical-start
default = ["nightly", "randomize"]
-randomize = ["rand", "rand_xoshiro"]
+# rust-analyzer depends on this crate and we therefore require it to built on a stable toolchain
+# without depending on rustc_data_structures, rustc_macros and rustc_serialize
nightly = [
"rustc_data_structures",
"rustc_index/nightly",
"rustc_macros",
"rustc_serialize",
]
+randomize = ["rand", "rand_xoshiro", "nightly"]
+# tidy-alphabetical-end