summaryrefslogtreecommitdiffstats
path: root/compiler/rustc_driver_impl/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'compiler/rustc_driver_impl/Cargo.toml')
-rw-r--r--compiler/rustc_driver_impl/Cargo.toml7
1 files changed, 5 insertions, 2 deletions
diff --git a/compiler/rustc_driver_impl/Cargo.toml b/compiler/rustc_driver_impl/Cargo.toml
index 7b59a52cf..73a1f79a0 100644
--- a/compiler/rustc_driver_impl/Cargo.toml
+++ b/compiler/rustc_driver_impl/Cargo.toml
@@ -54,8 +54,11 @@ rustc_hir_analysis = { path = "../rustc_hir_analysis" }
[target.'cfg(unix)'.dependencies]
libc = "0.2"
-[target.'cfg(windows)'.dependencies]
-winapi = { version = "0.3", features = ["consoleapi", "debugapi", "processenv"] }
+[target.'cfg(windows)'.dependencies.windows]
+version = "0.46.0"
+features = [
+ "Win32_System_Diagnostics_Debug",
+]
[features]
llvm = ['rustc_interface/llvm']