summaryrefslogtreecommitdiffstats
path: root/compiler/rustc_index/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'compiler/rustc_index/Cargo.toml')
-rw-r--r--compiler/rustc_index/Cargo.toml8
1 files changed, 6 insertions, 2 deletions
diff --git a/compiler/rustc_index/Cargo.toml b/compiler/rustc_index/Cargo.toml
index d8ea5aa80..e1cda5a9e 100644
--- a/compiler/rustc_index/Cargo.toml
+++ b/compiler/rustc_index/Cargo.toml
@@ -7,6 +7,10 @@ edition = "2021"
[dependencies]
arrayvec = { version = "0.7", default-features = false }
-rustc_serialize = { path = "../rustc_serialize" }
-rustc_macros = { path = "../rustc_macros" }
+rustc_serialize = { path = "../rustc_serialize", optional = true }
+rustc_macros = { path = "../rustc_macros", optional = true }
smallvec = "1.8.1"
+
+[features]
+default = ["nightly"]
+nightly = ["rustc_serialize", "rustc_macros"]