summaryrefslogtreecommitdiffstats
path: root/compiler/rustc_log/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'compiler/rustc_log/Cargo.toml')
-rw-r--r--compiler/rustc_log/Cargo.toml8
1 files changed, 7 insertions, 1 deletions
diff --git a/compiler/rustc_log/Cargo.toml b/compiler/rustc_log/Cargo.toml
index aa6e46cd8..6009a43e9 100644
--- a/compiler/rustc_log/Cargo.toml
+++ b/compiler/rustc_log/Cargo.toml
@@ -4,13 +4,19 @@ version = "0.0.0"
edition = "2021"
[dependencies]
+# tidy-alphabetical-start
tracing = "0.1.28"
+tracing-core = "=0.1.30" # FIXME(Nilstrieb) tracing has a deadlock: https://github.com/tokio-rs/tracing/issues/2635
tracing-subscriber = { version = "0.3.3", default-features = false, features = ["fmt", "env-filter", "smallvec", "parking_lot", "ansi"] }
tracing-tree = "0.2.0"
-tracing-core = "=0.1.30" # FIXME(Nilstrieb) tracing has a deadlock: https://github.com/tokio-rs/tracing/issues/2635
+# tidy-alphabetical-end
[dev-dependencies]
+# tidy-alphabetical-start
rustc_span = { path = "../rustc_span" }
+# tidy-alphabetical-end
[features]
+# tidy-alphabetical-start
max_level_info = ['tracing/max_level_info']
+# tidy-alphabetical-end