summaryrefslogtreecommitdiffstats
path: root/compiler/rustc_log
diff options
context:
space:
mode:
Diffstat (limited to 'compiler/rustc_log')
-rw-r--r--compiler/rustc_log/Cargo.toml1
-rw-r--r--compiler/rustc_log/src/lib.rs7
2 files changed, 4 insertions, 4 deletions
diff --git a/compiler/rustc_log/Cargo.toml b/compiler/rustc_log/Cargo.toml
index 1b2cde605..3c50827c1 100644
--- a/compiler/rustc_log/Cargo.toml
+++ b/compiler/rustc_log/Cargo.toml
@@ -4,7 +4,6 @@ version = "0.0.0"
edition = "2021"
[dependencies]
-atty = "0.2"
tracing = "0.1.28"
tracing-subscriber = { version = "0.3.3", default-features = false, features = ["fmt", "env-filter", "smallvec", "parking_lot", "ansi"] }
tracing-tree = "0.2.0"
diff --git a/compiler/rustc_log/src/lib.rs b/compiler/rustc_log/src/lib.rs
index 458f5e87b..ddf29c488 100644
--- a/compiler/rustc_log/src/lib.rs
+++ b/compiler/rustc_log/src/lib.rs
@@ -40,10 +40,11 @@
#![deny(rustc::untranslatable_diagnostic)]
#![deny(rustc::diagnostic_outside_of_impl)]
+#![feature(is_terminal)]
use std::env::{self, VarError};
use std::fmt::{self, Display};
-use std::io;
+use std::io::{self, IsTerminal};
use tracing_subscriber::filter::{Directive, EnvFilter, LevelFilter};
use tracing_subscriber::layer::SubscriberExt;
@@ -93,11 +94,11 @@ pub fn init_env_logger(env: &str) -> Result<(), Error> {
}
pub fn stdout_isatty() -> bool {
- atty::is(atty::Stream::Stdout)
+ io::stdout().is_terminal()
}
pub fn stderr_isatty() -> bool {
- atty::is(atty::Stream::Stderr)
+ io::stderr().is_terminal()
}
#[derive(Debug)]