summaryrefslogtreecommitdiffstats
path: root/compiler/rustc_target/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'compiler/rustc_target/Cargo.toml')
-rw-r--r--compiler/rustc_target/Cargo.toml15
1 files changed, 10 insertions, 5 deletions
diff --git a/compiler/rustc_target/Cargo.toml b/compiler/rustc_target/Cargo.toml
index 393e59e8b..94dfeb12d 100644
--- a/compiler/rustc_target/Cargo.toml
+++ b/compiler/rustc_target/Cargo.toml
@@ -4,18 +4,23 @@ version = "0.0.0"
edition = "2021"
[dependencies]
+# tidy-alphabetical-start
bitflags = "1.2.1"
-tracing = "0.1"
-serde_json = "1.0.59"
-rustc_fs_util = { path = "../rustc_fs_util" }
rustc_abi = { path = "../rustc_abi" }
rustc_data_structures = { path = "../rustc_data_structures" }
rustc_feature = { path = "../rustc_feature" }
+rustc_fs_util = { path = "../rustc_fs_util" }
+rustc_index = { path = "../rustc_index" }
rustc_macros = { path = "../rustc_macros" }
rustc_serialize = { path = "../rustc_serialize" }
rustc_span = { path = "../rustc_span" }
+serde_json = "1.0.59"
+tracing = "0.1"
+# tidy-alphabetical-end
[dependencies.object]
-version = "0.32.0"
+# tidy-alphabetical-start
default-features = false
-features = ["elf"]
+features = ["elf", "macho"]
+version = "0.32.0"
+# tidy-alphabetical-end