summaryrefslogtreecommitdiffstats
path: root/compiler/rustc_type_ir
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--compiler/rustc_type_ir/Cargo.toml1
-rw-r--r--compiler/rustc_type_ir/src/lib.rs6
-rw-r--r--compiler/rustc_type_ir/src/sty.rs4
3 files changed, 5 insertions, 6 deletions
diff --git a/compiler/rustc_type_ir/Cargo.toml b/compiler/rustc_type_ir/Cargo.toml
index 5aa3cf017..c4008e9b6 100644
--- a/compiler/rustc_type_ir/Cargo.toml
+++ b/compiler/rustc_type_ir/Cargo.toml
@@ -4,7 +4,6 @@ version = "0.0.0"
edition = "2021"
[lib]
-doctest = false
[dependencies]
bitflags = "1.2.1"
diff --git a/compiler/rustc_type_ir/src/lib.rs b/compiler/rustc_type_ir/src/lib.rs
index da30344ef..7fbe78aa5 100644
--- a/compiler/rustc_type_ir/src/lib.rs
+++ b/compiler/rustc_type_ir/src/lib.rs
@@ -675,9 +675,9 @@ impl<CTX> HashStable<CTX> for InferTy {
use InferTy::*;
discriminant(self).hash_stable(ctx, hasher);
match self {
- TyVar(v) => v.as_u32().hash_stable(ctx, hasher),
- IntVar(v) => v.index.hash_stable(ctx, hasher),
- FloatVar(v) => v.index.hash_stable(ctx, hasher),
+ TyVar(_) | IntVar(_) | FloatVar(_) => {
+ panic!("type variables should not be hashed: {self:?}")
+ }
FreshTy(v) | FreshIntTy(v) | FreshFloatTy(v) => v.hash_stable(ctx, hasher),
}
}
diff --git a/compiler/rustc_type_ir/src/sty.rs b/compiler/rustc_type_ir/src/sty.rs
index 6d54924e5..a4fb1480f 100644
--- a/compiler/rustc_type_ir/src/sty.rs
+++ b/compiler/rustc_type_ir/src/sty.rs
@@ -1332,8 +1332,8 @@ where
RePlaceholder(p) => {
p.hash_stable(hcx, hasher);
}
- ReVar(reg) => {
- reg.hash_stable(hcx, hasher);
+ ReVar(_) => {
+ panic!("region variables should not be hashed: {self:?}")
}
}
}