summaryrefslogtreecommitdiffstats
path: root/debian/control
diff options
context:
space:
mode:
Diffstat (limited to 'debian/control')
-rw-r--r--debian/control15
1 files changed, 8 insertions, 7 deletions
diff --git a/debian/control b/debian/control
index 227be03a8..35978d88b 100644
--- a/debian/control
+++ b/debian/control
@@ -14,19 +14,20 @@ Rules-Requires-Root: no
Build-Depends:
debhelper (>= 9),
debhelper-compat (= 13),
- dpkg-dev (>= 1.17.14),
python3:native,
- cargo:native (>= 1.73.0+dfsg) <!pkg.rustc.dlstage0>,
- rustc:native (>= 1.73.0+dfsg) <!pkg.rustc.dlstage0>,
- rustc:native (<= 1.74.1++) <!pkg.rustc.dlstage0>,
+ cargo:native (>= 1.74.0+dfsg) <!pkg.rustc.dlstage0>,
+ rustc:native (>= 1.74.0+dfsg) <!pkg.rustc.dlstage0>,
+ rustc:native (<= 1.75.0++) <!pkg.rustc.dlstage0>,
llvm-16-dev:native,
llvm-16-tools:native,
gcc-mingw-w64-x86-64-posix:native [amd64] <!nowindows>,
gcc-mingw-w64-i686-posix:native [i386] <!nowindows>,
libllvm16 (>= 1:16.0.0),
libclang-rt-16-dev:native,
+ libclang-rt-16-dev,
cmake (>= 3.0),
# needed by some vendor crates
+ pkgconf:native,
pkgconf,
# this is sometimes needed by rustc_llvm
zlib1g-dev:native,
@@ -89,7 +90,7 @@ Description: Rust systems programming language
generic programming and meta-programming, in both static and dynamic
styles.
-Package: libstd-rust-1.74
+Package: libstd-rust-1.75
Section: libs
Architecture: any
Multi-Arch: same
@@ -116,7 +117,7 @@ Section: libdevel
Architecture: any
Multi-Arch: same
Depends: ${shlibs:Depends}, ${misc:Depends},
- libstd-rust-1.74 (= ${binary:Version}),
+ libstd-rust-1.75 (= ${binary:Version}),
Description: Rust standard libraries - development files
Rust is a curly-brace, block-structured expression language. It
visually resembles the C language family, but differs significantly
@@ -311,7 +312,7 @@ Package: rust-clippy
Architecture: any
Multi-Arch: allowed
Depends: ${misc:Depends}, ${shlibs:Depends},
- libstd-rust-1.74 (= ${binary:Version})
+ libstd-rust-1.75 (= ${binary:Version})
Recommends: cargo
Description: Rust linter
Rust is a curly-brace, block-structured expression language. It