summaryrefslogtreecommitdiffstats
path: root/debian/patches/c-update-libgit2.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/c-update-libgit2.patch')
-rw-r--r--debian/patches/c-update-libgit2.patch26
1 files changed, 13 insertions, 13 deletions
diff --git a/debian/patches/c-update-libgit2.patch b/debian/patches/c-update-libgit2.patch
index 192571e46..c1d59a40a 100644
--- a/debian/patches/c-update-libgit2.patch
+++ b/debian/patches/c-update-libgit2.patch
@@ -2,26 +2,26 @@ Index: rust/src/tools/cargo/Cargo.toml
===================================================================
--- rust.orig/src/tools/cargo/Cargo.toml
+++ rust/src/tools/cargo/Cargo.toml
-@@ -33,8 +33,8 @@ env_logger = "0.10.0"
- filetime = "0.2.9"
- flate2 = { version = "1.0.3", default-features = false, features = ["zlib"] }
+@@ -37,8 +37,8 @@ curl-sys = "0.4.65"
+ filetime = "0.2.21"
+ flate2 = { version = "1.0.26", default-features = false, features = ["zlib"] }
fwdansi = "1.1.0"
--git2 = "0.17.1"
+-git2 = "0.17.2"
-git2-curl = "0.18.0"
+git2 = "0.18"
+git2-curl = "0.19.0"
gix = { version = "0.45.1", default-features = false, features = ["blocking-http-transport-curl", "progress-tree"] }
gix-features-for-configuration-only = { version = "0.30.0", package = "gix-features", features = [ "parallel" ] }
- glob = "0.3.0"
-@@ -52,7 +52,7 @@ jobserver = "0.1.26"
- lazy_static = "1.3.0"
- lazycell = "1.2.0"
- libc = "0.2.144"
--libgit2-sys = "0.15.1"
+ glob = "0.3.1"
+@@ -56,7 +56,7 @@ jobserver = "0.1.26"
+ lazy_static = "1.4.0"
+ lazycell = "1.3.0"
+ libc = "0.2.147"
+-libgit2-sys = "0.15.2"
+libgit2-sys = "0.16.1"
- log = "0.4.17"
- memchr = "2.1.3"
- miow = "0.5.0"
+ libloading = "0.8.0"
+ memchr = "2.5.0"
+ miow = "0.6.0"
Index: rust/src/tools/cargo/crates/cargo-test-support/Cargo.toml
===================================================================
--- rust.orig/src/tools/cargo/crates/cargo-test-support/Cargo.toml