summaryrefslogtreecommitdiffstats
path: root/debian/patches/c-update-libgit2.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/c-update-libgit2.patch')
-rw-r--r--debian/patches/c-update-libgit2.patch26
1 files changed, 13 insertions, 13 deletions
diff --git a/debian/patches/c-update-libgit2.patch b/debian/patches/c-update-libgit2.patch
index b004ed095..8fe7c1ca9 100644
--- a/debian/patches/c-update-libgit2.patch
+++ b/debian/patches/c-update-libgit2.patch
@@ -2,31 +2,31 @@ Index: rust/src/tools/cargo/Cargo.toml
===================================================================
--- rust.orig/src/tools/cargo/Cargo.toml
+++ rust/src/tools/cargo/Cargo.toml
-@@ -28,8 +28,8 @@ curl-sys = "0.4.61"
- env_logger = "0.10.0"
+@@ -33,8 +33,8 @@ env_logger = "0.10.0"
filetime = "0.2.9"
flate2 = { version = "1.0.3", default-features = false, features = ["zlib"] }
--git2 = "0.17.0"
+ fwdansi = "1.1.0"
+-git2 = "0.17.1"
-git2-curl = "0.18.0"
-+git2 = "0.18.0"
++git2 = "0.18"
+git2-curl = "0.19.0"
- gix = { version = "0.39.0", default-features = false, features = ["blocking-http-transport-curl", "progress-tree"] }
- gix-features-for-configuration-only = { version = "0.28.0", package = "gix-features", features = [ "parallel" ] }
+ gix = { version = "0.44.1", default-features = false, features = ["blocking-http-transport-curl", "progress-tree"] }
+ gix-features-for-configuration-only = { version = "0.29.0", package = "gix-features", features = [ "parallel" ] }
glob = "0.3.0"
-@@ -47,7 +47,7 @@ jobserver = "0.1.26"
- lazy_static = "1.2.0"
+@@ -53,7 +53,7 @@ jobserver = "0.1.26"
+ lazy_static = "1.3.0"
lazycell = "1.2.0"
- libc = "0.2"
--libgit2-sys = "0.15.0"
+ libc = "0.2.144"
+-libgit2-sys = "0.15.1"
+libgit2-sys = "0.16.1"
- log = "0.4.6"
+ log = "0.4.17"
memchr = "2.1.3"
- opener = "0.5"
+ miow = "0.5.0"
Index: rust/src/tools/cargo/crates/cargo-test-support/Cargo.toml
===================================================================
--- rust.orig/src/tools/cargo/crates/cargo-test-support/Cargo.toml
+++ rust/src/tools/cargo/crates/cargo-test-support/Cargo.toml
-@@ -14,7 +14,7 @@ cargo-util = { path = "../cargo-util" }
+@@ -15,7 +15,7 @@ cargo-util = { path = "../cargo-util" }
crates-io = { path = "../crates-io" }
filetime = "0.2"
flate2 = { version = "1.0", default-features = false, features = ["zlib"] }