summaryrefslogtreecommitdiffstats
path: root/debian/patches/d-0010-cargo-remove-vendored-c-crates.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/d-0010-cargo-remove-vendored-c-crates.patch')
-rw-r--r--debian/patches/d-0010-cargo-remove-vendored-c-crates.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/debian/patches/d-0010-cargo-remove-vendored-c-crates.patch b/debian/patches/d-0010-cargo-remove-vendored-c-crates.patch
new file mode 100644
index 000000000..b386a3a5f
--- /dev/null
+++ b/debian/patches/d-0010-cargo-remove-vendored-c-crates.patch
@@ -0,0 +1,18 @@
+Description: Remove embeded C libraries in bundled crates
+Author: Zixing Liu <zixing.liu@canonical.com>
+Forwarded: not-needed
+Last-Update: 2023-05-17
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+Index: rust/src/tools/cargo/Cargo.toml
+===================================================================
+--- rust.orig/src/tools/cargo/Cargo.toml
++++ rust/src/tools/cargo/Cargo.toml
+@@ -114,6 +114,5 @@ test = false
+ doc = false
+
+ [features]
+-vendored-openssl = ["openssl/vendored"]
+-vendored-libgit2 = ["libgit2-sys/vendored"]
++# Debian: removed vendoring flags
+ pretty-env-logger = ["pretty_env_logger"]