summaryrefslogtreecommitdiffstats
path: root/debian/patches/d-fix-rustix-outline.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/d-fix-rustix-outline.patch')
-rw-r--r--debian/patches/d-fix-rustix-outline.patch86
1 files changed, 84 insertions, 2 deletions
diff --git a/debian/patches/d-fix-rustix-outline.patch b/debian/patches/d-fix-rustix-outline.patch
index 99fd7e958..3431ebfff 100644
--- a/debian/patches/d-fix-rustix-outline.patch
+++ b/debian/patches/d-fix-rustix-outline.patch
@@ -12,7 +12,7 @@ Index: rust/vendor/rustix/build.rs
use cc::Build;
use std::env::var;
use std::io::Write;
-@@ -162,16 +161,16 @@ fn link_in_librustix_outline(arch: &str,
+@@ -165,16 +164,16 @@ fn link_in_librustix_outline(arch: &str,
println!("cargo:rerun-if-changed={}", to);
// If "cc" is not enabled, use a pre-built library.
@@ -36,7 +36,89 @@ Index: rust/vendor/rustix/Cargo.toml
===================================================================
--- rust.orig/vendor/rustix/Cargo.toml
+++ rust/vendor/rustix/Cargo.toml
-@@ -127,7 +127,6 @@ version = "3.4.0"
+@@ -117,7 +117,6 @@ version = "3.5.0"
+
+ [build-dependencies.cc]
+ version = "1.0.68"
+-optional = true
+
+ [features]
+ all-apis = [
+Index: rust/vendor/rustix-0.37.11/build.rs
+===================================================================
+--- rust.orig/vendor/rustix-0.37.11/build.rs
++++ rust/vendor/rustix-0.37.11/build.rs
+@@ -1,4 +1,3 @@
+-#[cfg(feature = "cc")]
+ use cc::Build;
+ use std::env::var;
+ use std::io::Write;
+@@ -165,16 +164,16 @@ fn link_in_librustix_outline(arch: &str,
+ println!("cargo:rerun-if-changed={}", to);
+
+ // If "cc" is not enabled, use a pre-built library.
+- #[cfg(not(feature = "cc"))]
++ /*#[cfg(not(feature = "cc"))]
+ {
+ let _ = asm_name;
+ println!("cargo:rustc-link-search={}/{}", OUTLINE_PATH, profile);
+ println!("cargo:rustc-link-lib=static={}", name);
+- }
++ }*/
+
+ // If "cc" is enabled, build the library from source, update the pre-built
+ // version, and assert that the pre-built version is checked in.
+- #[cfg(feature = "cc")]
++ //#[cfg(feature = "cc")]
+ {
+ let out_dir = var("OUT_DIR").unwrap();
+ // Add `-gdwarf-3` so that we always get the same output, regardless of
+Index: rust/vendor/rustix-0.37.11/Cargo.toml
+===================================================================
+--- rust.orig/vendor/rustix-0.37.11/Cargo.toml
++++ rust/vendor/rustix-0.37.11/Cargo.toml
+@@ -117,7 +117,6 @@ version = "3.5.0"
+
+ [build-dependencies.cc]
+ version = "1.0.68"
+-optional = true
+
+ [features]
+ all-apis = [
+Index: rust/vendor/rustix-0.37.20/build.rs
+===================================================================
+--- rust.orig/vendor/rustix-0.37.20/build.rs
++++ rust/vendor/rustix-0.37.20/build.rs
+@@ -1,4 +1,3 @@
+-#[cfg(feature = "cc")]
+ use cc::Build;
+ use std::env::var;
+ use std::io::Write;
+@@ -165,16 +164,16 @@ fn link_in_librustix_outline(arch: &str,
+ println!("cargo:rerun-if-changed={}", to);
+
+ // If "cc" is not enabled, use a pre-built library.
+- #[cfg(not(feature = "cc"))]
++ /*#[cfg(not(feature = "cc"))]
+ {
+ let _ = asm_name;
+ println!("cargo:rustc-link-search={}/{}", OUTLINE_PATH, profile);
+ println!("cargo:rustc-link-lib=static={}", name);
+- }
++ }*/
+
+ // If "cc" is enabled, build the library from source, update the pre-built
+ // version, and assert that the pre-built version is checked in.
+- #[cfg(feature = "cc")]
++ //#[cfg(feature = "cc")]
+ {
+ let out_dir = var("OUT_DIR").unwrap();
+ // Add `-gdwarf-3` so that we always get the same output, regardless of
+Index: rust/vendor/rustix-0.37.20/Cargo.toml
+===================================================================
+--- rust.orig/vendor/rustix-0.37.20/Cargo.toml
++++ rust/vendor/rustix-0.37.20/Cargo.toml
+@@ -117,7 +117,6 @@ version = "3.5.0"
[build-dependencies.cc]
version = "1.0.68"