summaryrefslogtreecommitdiffstats
path: root/debian/patches/d-fix-rustix-outline.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/d-fix-rustix-outline.patch')
-rw-r--r--debian/patches/d-fix-rustix-outline.patch46
1 files changed, 0 insertions, 46 deletions
diff --git a/debian/patches/d-fix-rustix-outline.patch b/debian/patches/d-fix-rustix-outline.patch
deleted file mode 100644
index 4ac594d0d..000000000
--- a/debian/patches/d-fix-rustix-outline.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-Always enable cc even if the feature is not enabled.
-
-Some Debian architectures need outline asm, and Debian does not ship pre-built
-outline asm.
-
-Index: rust/vendor/rustix-0.37.6/build.rs
-===================================================================
---- rust.orig/vendor/rustix-0.37.6/build.rs
-+++ rust/vendor/rustix-0.37.6/build.rs
-@@ -1,4 +1,3 @@
--#[cfg(feature = "cc")]
- use cc::Build;
- use std::env::var;
- use std::io::Write;
-@@ -158,16 +157,16 @@ fn link_in_librustix_outline(arch: &str,
- println!("cargo:rerun-if-changed={}", to);
-
- // If "cc" is not enabled, use a pre-built library.
-- #[cfg(not(feature = "cc"))]
-+ /*#[cfg(not(feature = "cc"))]
- {
- let _ = asm_name;
- println!("cargo:rustc-link-search={}/{}", OUTLINE_PATH, profile);
- println!("cargo:rustc-link-lib=static={}", name);
-- }
-+ }*/
-
- // If "cc" is enabled, build the library from source, update the pre-built
- // version, and assert that the pre-built version is checked in.
-- #[cfg(feature = "cc")]
-+ //#[cfg(feature = "cc")]
- {
- let out_dir = var("OUT_DIR").unwrap();
- // Add `-gdwarf-3` so that we always get the same output, regardless of
-Index: rust/vendor/rustix-0.37.6/Cargo.toml
-===================================================================
---- rust.orig/vendor/rustix-0.37.6/Cargo.toml
-+++ rust/vendor/rustix-0.37.6/Cargo.toml
-@@ -127,7 +127,6 @@ version = "3.4.0"
-
- [build-dependencies.cc]
- version = "1.0.68"
--optional = true
-
- [features]
- all-apis = [