summaryrefslogtreecommitdiffstats
path: root/debian/patches/prune/d-0000-ignore-removed-submodules.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/prune/d-0000-ignore-removed-submodules.patch')
-rw-r--r--debian/patches/prune/d-0000-ignore-removed-submodules.patch246
1 files changed, 246 insertions, 0 deletions
diff --git a/debian/patches/prune/d-0000-ignore-removed-submodules.patch b/debian/patches/prune/d-0000-ignore-removed-submodules.patch
new file mode 100644
index 000000000..f3a7b7030
--- /dev/null
+++ b/debian/patches/prune/d-0000-ignore-removed-submodules.patch
@@ -0,0 +1,246 @@
+From: Debian Rust Maintainers <pkg-rust-maintainers@alioth-lists.debian.net>
+Date: Sat, 2 Oct 2021 01:07:59 +0100
+Subject: d-0000-ignore-removed-submodules
+
+Description: remove upstream parts that are not needed for the Debian build, in
+order to both reduce the orig tarball and the vendored crates within.
+
+Forwarded: not-needed
+---
+ Cargo.toml | 7 ----
+ src/bootstrap/bootstrap.py | 4 ---
+ src/bootstrap/src/core/build_steps/test.rs | 12 +------
+ src/bootstrap/src/core/builder.rs | 54 +++++++-----------------------
+ src/tools/rust-analyzer/Cargo.toml | 11 +++++-
+ 5 files changed, 24 insertions(+), 64 deletions(-)
+
+diff --git a/Cargo.toml b/Cargo.toml
+index 9b11ae8..19a98f9 100644
+--- a/Cargo.toml
++++ b/Cargo.toml
+@@ -19,22 +19,15 @@ members = [
+ "src/tools/tidy",
+ "src/tools/tier-check",
+ "src/tools/build-manifest",
+- "src/tools/remote-test-client",
+- "src/tools/remote-test-server",
+ "src/tools/rust-installer",
+ "src/tools/rust-demangler",
+ "src/tools/rustdoc",
+- "src/tools/rls",
+ "src/tools/rustfmt",
+- "src/tools/miri",
+- "src/tools/miri/cargo-miri",
+ "src/tools/rustdoc-themes",
+ "src/tools/unicode-table-generator",
+- "src/tools/expand-yaml-anchors",
+ "src/tools/jsondocck",
+ "src/tools/jsondoclint",
+ "src/tools/html-checker",
+- "src/tools/bump-stage0",
+ "src/tools/replace-version-placeholder",
+ "src/tools/lld-wrapper",
+ "src/tools/collect-license-metadata",
+diff --git a/src/bootstrap/bootstrap.py b/src/bootstrap/bootstrap.py
+index fea194a..ed99a47 100644
+--- a/src/bootstrap/bootstrap.py
++++ b/src/bootstrap/bootstrap.py
+@@ -955,10 +955,6 @@ class RustBuild(object):
+ args = [self.cargo(), "build", "--manifest-path",
+ os.path.join(self.rust_root, "src/bootstrap/Cargo.toml")]
+ args.extend("--verbose" for _ in range(self.verbose))
+- if self.use_locked_deps:
+- args.append("--locked")
+- if self.use_vendored_sources:
+- args.append("--frozen")
+ if self.get_toml("metrics", "build"):
+ args.append("--features")
+ args.append("build-metrics")
+diff --git a/src/bootstrap/src/core/build_steps/test.rs b/src/bootstrap/src/core/build_steps/test.rs
+index 4eb7766..5c115cf 100644
+--- a/src/bootstrap/src/core/build_steps/test.rs
++++ b/src/bootstrap/src/core/build_steps/test.rs
+@@ -2295,17 +2295,7 @@ impl Step for RustcGuide {
+ }
+
+ fn run(self, builder: &Builder<'_>) {
+- let relative_path = Path::new("src").join("doc").join("rustc-dev-guide");
+- builder.update_submodule(&relative_path);
+-
+- let src = builder.src.join(relative_path);
+- let mut rustbook_cmd = builder.tool_cmd(Tool::Rustbook);
+- let toolstate = if builder.run_delaying_failure(rustbook_cmd.arg("linkcheck").arg(&src)) {
+- ToolState::TestPass
+- } else {
+- ToolState::TestFail
+- };
+- builder.save_toolstate("rustc-dev-guide", toolstate);
++ builder.save_toolstate("rustc-dev-guide", ToolState::TestPass);
+ }
+ }
+
+diff --git a/src/bootstrap/src/core/builder.rs b/src/bootstrap/src/core/builder.rs
+index e180964..7245d11 100644
+--- a/src/bootstrap/src/core/builder.rs
++++ b/src/bootstrap/src/core/builder.rs
+@@ -498,20 +498,20 @@ impl<'a> ShouldRun<'a> {
+ static SUBMODULES_PATHS: OnceLock<Vec<String>> = OnceLock::new();
+
+ let init_submodules_paths = |src: &PathBuf| {
+- let file = File::open(src.join(".gitmodules")).unwrap();
++ //let file = File::open(src.join(".gitmodules")).unwrap();
+
+ let mut submodules_paths = vec![];
+- for line in BufReader::new(file).lines() {
+- if let Ok(line) = line {
+- let line = line.trim();
+-
+- if line.starts_with("path") {
+- let actual_path =
+- line.split(' ').last().expect("Couldn't get value of path");
+- submodules_paths.push(actual_path.to_owned());
+- }
+- }
+- }
++ //for line in BufReader::new(file).lines() {
++ // if let Ok(line) = line {
++ // let line = line.trim();
++
++ // if line.starts_with("path") {
++ // let actual_path =
++ // line.split(' ').last().expect("Couldn't get value of path");
++ // submodules_paths.push(actual_path.to_owned());
++ // }
++ // }
++ //}
+
+ submodules_paths
+ };
+@@ -685,25 +685,14 @@ impl<'a> Builder<'a> {
+ tool::Linkchecker,
+ tool::CargoTest,
+ tool::Compiletest,
+- tool::RemoteTestServer,
+- tool::RemoteTestClient,
+ tool::RustInstaller,
+ tool::Cargo,
+- tool::Rls,
+- tool::RustAnalyzer,
+ tool::RustAnalyzerProcMacroSrv,
+ tool::RustDemangler,
+ tool::Rustdoc,
+ tool::Clippy,
+ tool::CargoClippy,
+- llvm::Llvm,
+- llvm::Sanitizers,
+ tool::Rustfmt,
+- tool::Miri,
+- tool::CargoMiri,
+- llvm::Lld,
+- llvm::CrtBeginEnd,
+- tool::RustdocGUITest,
+ tool::OptimizedDist,
+ tool::CoverageDump,
+ ),
+@@ -713,12 +702,7 @@ impl<'a> Builder<'a> {
+ check::Rustdoc,
+ check::CodegenBackend,
+ check::Clippy,
+- check::Miri,
+- check::CargoMiri,
+- check::MiroptTestTools,
+- check::Rls,
+ check::Rustfmt,
+- check::RustAnalyzer,
+ check::Bootstrap
+ ),
+ Kind::Test => describe!(
+@@ -751,7 +735,6 @@ impl<'a> Builder<'a> {
+ test::TierCheck,
+ test::Cargotest,
+ test::Cargo,
+- test::RustAnalyzer,
+ test::ErrorIndex,
+ test::Distcheck,
+ test::RunMakeFullDeps,
+@@ -767,7 +750,6 @@ impl<'a> Builder<'a> {
+ test::EmbeddedBook,
+ test::EditionGuide,
+ test::Rustfmt,
+- test::Miri,
+ test::Clippy,
+ test::RustDemangler,
+ test::CompiletestTest,
+@@ -804,7 +786,6 @@ impl<'a> Builder<'a> {
+ doc::CargoBook,
+ doc::Clippy,
+ doc::ClippyBook,
+- doc::Miri,
+ doc::EmbeddedBook,
+ doc::EditionGuide,
+ doc::StyleGuide,
+@@ -824,12 +805,9 @@ impl<'a> Builder<'a> {
+ dist::Analysis,
+ dist::Src,
+ dist::Cargo,
+- dist::Rls,
+- dist::RustAnalyzer,
+ dist::Rustfmt,
+ dist::RustDemangler,
+ dist::Clippy,
+- dist::Miri,
+ dist::LlvmTools,
+ dist::RustDev,
+ dist::Bootstrap,
+@@ -846,11 +824,9 @@ impl<'a> Builder<'a> {
+ install::Docs,
+ install::Std,
+ install::Cargo,
+- install::RustAnalyzer,
+ install::Rustfmt,
+ install::RustDemangler,
+ install::Clippy,
+- install::Miri,
+ install::LlvmTools,
+ install::Src,
+ install::Rustc
+@@ -860,7 +836,6 @@ impl<'a> Builder<'a> {
+ run::BuildManifest,
+ run::BumpStage0,
+ run::ReplaceVersionPlaceholder,
+- run::Miri,
+ run::CollectLicenseMetadata,
+ run::GenerateCopyright,
+ run::GenerateWindowsSys,
+@@ -2080,10 +2055,7 @@ impl<'a> Builder<'a> {
+ }
+ }
+
+- if self.config.locked_deps {
+- cargo.arg("--locked");
+- }
+- if self.config.vendor || self.is_sudo {
++ if self.is_sudo {
+ cargo.arg("--frozen");
+ }
+
+diff --git a/src/tools/rust-analyzer/Cargo.toml b/src/tools/rust-analyzer/Cargo.toml
+index 1213979..71f9aa7 100644
+--- a/src/tools/rust-analyzer/Cargo.toml
++++ b/src/tools/rust-analyzer/Cargo.toml
+@@ -1,5 +1,14 @@
+ [workspace]
+-members = ["xtask/", "lib/*", "crates/*"]
++members = [
++ "xtask/",
++ "lib/*",
++ "crates/proc-macro-srv",
++ "crates/proc-macro-srv-cli",
++ "crates/tt",
++ "crates/mbe",
++ "crates/paths",
++ "crates/proc-macro-api",
++]
+ exclude = ["crates/proc-macro-test/imp"]
+ resolver = "2"
+