summaryrefslogtreecommitdiffstats
path: root/debian/patches/prune/d-0005-no-jemalloc.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/prune/d-0005-no-jemalloc.patch')
-rw-r--r--debian/patches/prune/d-0005-no-jemalloc.patch51
1 files changed, 51 insertions, 0 deletions
diff --git a/debian/patches/prune/d-0005-no-jemalloc.patch b/debian/patches/prune/d-0005-no-jemalloc.patch
new file mode 100644
index 000000000..611b87028
--- /dev/null
+++ b/debian/patches/prune/d-0005-no-jemalloc.patch
@@ -0,0 +1,51 @@
+From: Debian Rust Maintainers <pkg-rust-maintainers@alioth-lists.debian.net>
+Date: Sat, 2 Oct 2021 01:08:00 +0100
+Subject: d-0005-no-jemalloc
+
+Description: remove jemalloc-sys
+
+Forwarded: not-needed
+---
+ compiler/rustc/Cargo.toml | 6 ------
+ src/tools/rust-analyzer/crates/profile/Cargo.toml | 2 --
+ 2 files changed, 8 deletions(-)
+
+diff --git a/compiler/rustc/Cargo.toml b/compiler/rustc/Cargo.toml
+index 3cb56a7..af37dfc 100644
+--- a/compiler/rustc/Cargo.toml
++++ b/compiler/rustc/Cargo.toml
+@@ -20,14 +20,8 @@ rustc_smir = { path = "../rustc_smir" }
+ stable_mir = { path = "../stable_mir" }
+ # tidy-alphabetical-end
+
+-[dependencies.jemalloc-sys]
+-version = "0.5.0"
+-optional = true
+-features = ['unprefixed_malloc_on_supported_platforms']
+-
+ [features]
+ # tidy-alphabetical-start
+-jemalloc = ['jemalloc-sys']
+ llvm = ['rustc_driver_impl/llvm']
+ max_level_info = ['rustc_driver_impl/max_level_info']
+ rustc_use_parallel_compiler = ['rustc_driver_impl/rustc_use_parallel_compiler']
+diff --git a/src/tools/rust-analyzer/crates/profile/Cargo.toml b/src/tools/rust-analyzer/crates/profile/Cargo.toml
+index 56ce9d1..4fb2760 100644
+--- a/src/tools/rust-analyzer/crates/profile/Cargo.toml
++++ b/src/tools/rust-analyzer/crates/profile/Cargo.toml
+@@ -17,7 +17,6 @@ cfg-if = "1.0.0"
+ la-arena.workspace = true
+ libc.workspace = true
+ countme = { version = "3.0.1", features = ["enable"] }
+-jemalloc-ctl = { version = "0.5.0", package = "tikv-jemalloc-ctl", optional = true }
+
+ [target.'cfg(target_os = "linux")'.dependencies]
+ perf-event = "=0.4.7"
+@@ -27,7 +26,6 @@ winapi = { version = "0.3.9", features = ["processthreadsapi", "psapi"] }
+
+ [features]
+ cpu_profiler = []
+-jemalloc = ["jemalloc-ctl"]
+
+ # Uncomment to enable for the whole crate graph
+ # default = [ "cpu_profiler" ]