summaryrefslogtreecommitdiffstats
path: root/debian/patches/prune/d-0010-cargo-remove-vendored-c-crates.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/prune/d-0010-cargo-remove-vendored-c-crates.patch')
-rw-r--r--debian/patches/prune/d-0010-cargo-remove-vendored-c-crates.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/debian/patches/prune/d-0010-cargo-remove-vendored-c-crates.patch b/debian/patches/prune/d-0010-cargo-remove-vendored-c-crates.patch
new file mode 100644
index 000000000..30b3198b4
--- /dev/null
+++ b/debian/patches/prune/d-0010-cargo-remove-vendored-c-crates.patch
@@ -0,0 +1,39 @@
+From: Debian Rust Maintainers <pkg-rust-maintainers@alioth-lists.debian.net>
+Date: Mon, 6 May 2024 10:25:32 +0200
+Subject: d-0010-cargo-remove-vendored-c-crates
+
+Description: remove all vendoring features of crates normally shipping bundled
+C libs. that C code is stripped when repacking, so the features can't work
+anyway.
+Last-Update: 2023-05-17
+
+Forwarded: not-needed
+---
+ src/tools/cargo/Cargo.toml | 6 ++----
+ 1 file changed, 2 insertions(+), 4 deletions(-)
+
+diff --git a/src/tools/cargo/Cargo.toml b/src/tools/cargo/Cargo.toml
+index c07b004..2a81642 100644
+--- a/src/tools/cargo/Cargo.toml
++++ b/src/tools/cargo/Cargo.toml
+@@ -73,7 +73,7 @@ proptest = "1.4.0"
+ pulldown-cmark = { version = "0.9.3", default-features = false }
+ rand = "0.8.5"
+ regex = "1.10.2"
+-rusqlite = { version = "0.30.0", features = ["bundled"] }
++rusqlite = { version = "0.30.0", features = [] }
+ rustfix = { version = "0.7.0", path = "crates/rustfix" }
+ same-file = "1.0.6"
+ security-framework = "2.9.2"
+@@ -243,10 +243,8 @@ test = false
+ doc = false
+
+ [features]
+-vendored-openssl = ["openssl/vendored"]
+-vendored-libgit2 = ["libgit2-sys/vendored"]
++# Debian: removed vendoring flags
+ # This is primarily used by rust-lang/rust distributing cargo the executable.
+-all-static = ['vendored-openssl', 'curl/static-curl', 'curl/force-system-lib-on-osx', 'vendored-libgit2']
+
+ [lints]
+ workspace = true