summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 3 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index c7b05413c..eb6a2a4d1 100755
--- a/debian/rules
+++ b/debian/rules
@@ -332,10 +332,10 @@ endif
ifneq (,$(filter $(DEB_BUILD_ARCH), mipsel))
FAILURES_ALLOWED = 25
endif
-ifneq (,$(filter $(DEB_BUILD_ARCH), ppc64 s390x))
+ifneq (,$(filter $(DEB_BUILD_ARCH), ppc64 s390x riscv64))
FAILURES_ALLOWED = 40
endif
-ifneq (,$(filter $(DEB_BUILD_ARCH), powerpc powerpcspe riscv64 sparc64 x32))
+ifneq (,$(filter $(DEB_BUILD_ARCH), loong64 powerpc powerpcspe sparc64 x32))
FAILURES_ALLOWED = 180
endif
FAILED_TESTS = grep "FAILED\|^command did not execute successfully" $(TEST_LOG) | grep -v '^test result: FAILED' | grep -v 'FAILED (allowed)'
@@ -517,7 +517,7 @@ override_dh_dwz:
dh_dwz --no-dwz-multifile
override_dh_makeshlibs:
- dh_makeshlibs -V
+ dh_makeshlibs -V -N $(LIBSTD_PKG)
# dh_makeshlibs doesn't support our "libfoo-version.so" naming
# structure, so we have to do this ourselves.