summaryrefslogtreecommitdiffstats
path: root/extra/libgit2-sys/debian
diff options
context:
space:
mode:
Diffstat (limited to 'extra/libgit2-sys/debian')
-rw-r--r--extra/libgit2-sys/debian/patches/disable-vendor.patch26
-rw-r--r--extra/libgit2-sys/debian/patches/remove-zlib-ng-compat.patch15
-rw-r--r--extra/libgit2-sys/debian/patches/series2
3 files changed, 43 insertions, 0 deletions
diff --git a/extra/libgit2-sys/debian/patches/disable-vendor.patch b/extra/libgit2-sys/debian/patches/disable-vendor.patch
new file mode 100644
index 000000000..fe20e2315
--- /dev/null
+++ b/extra/libgit2-sys/debian/patches/disable-vendor.patch
@@ -0,0 +1,26 @@
+Index: libgit2-sys/Cargo.toml
+===================================================================
+--- libgit2-sys.orig/Cargo.toml
++++ libgit2-sys/Cargo.toml
+@@ -57,8 +57,6 @@ version = "0.3.15"
+ https = ["openssl-sys"]
+ ssh = ["libssh2-sys"]
+ ssh_key_from_memory = []
+-vendored = []
+-vendored-openssl = ["openssl-sys/vendored"]
+
+ [target."cfg(unix)".dependencies.openssl-sys]
+ version = "0.9.45"
+Index: libgit2-sys/build.rs
+===================================================================
+--- libgit2-sys.orig/build.rs
++++ libgit2-sys/build.rs
+@@ -55,6 +55,8 @@ The build is now aborting. To disable, u
+ return;
+ }
+
++ panic!("debian build must never use vendored libgit2!");
++
+ println!("cargo:rustc-cfg=libgit2_vendored");
+
+ if !Path::new("libgit2/src").exists() {
diff --git a/extra/libgit2-sys/debian/patches/remove-zlib-ng-compat.patch b/extra/libgit2-sys/debian/patches/remove-zlib-ng-compat.patch
new file mode 100644
index 000000000..5e5b44e5e
--- /dev/null
+++ b/extra/libgit2-sys/debian/patches/remove-zlib-ng-compat.patch
@@ -0,0 +1,15 @@
+Index: libgit2-sys/Cargo.toml
+===================================================================
+--- libgit2-sys.orig/Cargo.toml
++++ libgit2-sys/Cargo.toml
+@@ -59,10 +59,6 @@ ssh = ["libssh2-sys"]
+ ssh_key_from_memory = []
+ vendored = []
+ vendored-openssl = ["openssl-sys/vendored"]
+-zlib-ng-compat = [
+- "libz-sys/zlib-ng",
+- "libssh2-sys?/zlib-ng-compat",
+-]
+
+ [target."cfg(unix)".dependencies.openssl-sys]
+ version = "0.9.45"
diff --git a/extra/libgit2-sys/debian/patches/series b/extra/libgit2-sys/debian/patches/series
new file mode 100644
index 000000000..90136830c
--- /dev/null
+++ b/extra/libgit2-sys/debian/patches/series
@@ -0,0 +1,2 @@
+remove-zlib-ng-compat.patch
+disable-vendor.patch