summaryrefslogtreecommitdiffstats
path: root/library/backtrace/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'library/backtrace/Cargo.toml')
-rw-r--r--library/backtrace/Cargo.toml12
1 files changed, 7 insertions, 5 deletions
diff --git a/library/backtrace/Cargo.toml b/library/backtrace/Cargo.toml
index cff2c9e66..6714b3b7d 100644
--- a/library/backtrace/Cargo.toml
+++ b/library/backtrace/Cargo.toml
@@ -1,6 +1,6 @@
[package]
name = "backtrace"
-version = "0.3.68"
+version = "0.3.69"
authors = ["The Rust Project Developers"]
build = "build.rs"
license = "MIT OR Apache-2.0"
@@ -14,6 +14,7 @@ A library to acquire a stack trace (backtrace) at runtime in a Rust program.
autoexamples = true
autotests = true
edition = "2018"
+exclude = ["/ci/"]
[workspace]
members = ['crates/cpp_smoke_test', 'crates/as-if-std']
@@ -27,7 +28,6 @@ exclude = [
[dependencies]
cfg-if = "1.0"
rustc-demangle = "0.1.4"
-libc = { version = "0.2.146", default-features = false }
# Optionally enable the ability to serialize a `Backtrace`, controlled through
# the `serialize-*` features below.
@@ -37,11 +37,13 @@ rustc-serialize = { version = "0.3", optional = true }
# Optionally demangle C++ frames' symbols in backtraces.
cpp_demangle = { default-features = false, version = "0.4.0", optional = true, features = ["alloc"] }
-addr2line = { version = "0.20.0", default-features = false }
+[target.'cfg(not(all(windows, target_env = "msvc", not(target_vendor = "uwp"))))'.dependencies]
miniz_oxide = { version = "0.7.0", default-features = false }
+addr2line = { version = "0.21.0", default-features = false }
+libc = { version = "0.2.146", default-features = false }
-[dependencies.object]
-version = "0.31.1"
+[target.'cfg(not(all(windows, target_env = "msvc", not(target_vendor = "uwp"))))'.dependencies.object]
+version = "0.32.0"
default-features = false
features = ['read_core', 'elf', 'macho', 'pe', 'unaligned', 'archive']