summaryrefslogtreecommitdiffstats
path: root/library/panic_abort/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'library/panic_abort/Cargo.toml')
-rw-r--r--library/panic_abort/Cargo.toml19
1 files changed, 19 insertions, 0 deletions
diff --git a/library/panic_abort/Cargo.toml b/library/panic_abort/Cargo.toml
new file mode 100644
index 000000000..46183d1ad
--- /dev/null
+++ b/library/panic_abort/Cargo.toml
@@ -0,0 +1,19 @@
+[package]
+name = "panic_abort"
+version = "0.0.0"
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/rust-lang/rust.git"
+description = "Implementation of Rust panics via process aborts"
+edition = "2021"
+
+[lib]
+test = false
+bench = false
+doc = false
+
+[dependencies]
+alloc = { path = "../alloc" }
+cfg-if = { version = "0.1.8", features = ['rustc-dep-of-std'] }
+core = { path = "../core" }
+libc = { version = "0.2", default-features = false }
+compiler_builtins = "0.1.0"