summaryrefslogtreecommitdiffstats
path: root/library/std/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'library/std/Cargo.toml')
-rw-r--r--library/std/Cargo.toml86
1 files changed, 86 insertions, 0 deletions
diff --git a/library/std/Cargo.toml b/library/std/Cargo.toml
new file mode 100644
index 000000000..229e546e0
--- /dev/null
+++ b/library/std/Cargo.toml
@@ -0,0 +1,86 @@
+[package]
+name = "std"
+version = "0.0.0"
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/rust-lang/rust.git"
+description = "The Rust Standard Library"
+edition = "2021"
+
+[lib]
+crate-type = ["dylib", "rlib"]
+
+[dependencies]
+alloc = { path = "../alloc" }
+cfg-if = { version = "0.1.8", features = ['rustc-dep-of-std'] }
+panic_unwind = { path = "../panic_unwind", optional = true }
+panic_abort = { path = "../panic_abort" }
+core = { path = "../core" }
+libc = { version = "0.2.126", default-features = false, features = ['rustc-dep-of-std'] }
+compiler_builtins = { version = "0.1.73" }
+profiler_builtins = { path = "../profiler_builtins", optional = true }
+unwind = { path = "../unwind" }
+hashbrown = { version = "0.12", default-features = false, features = ['rustc-dep-of-std'] }
+std_detect = { path = "../stdarch/crates/std_detect", default-features = false, features = ['rustc-dep-of-std'] }
+
+# Dependencies of the `backtrace` crate
+addr2line = { version = "0.16.0", optional = true, default-features = false }
+rustc-demangle = { version = "0.1.21", features = ['rustc-dep-of-std'] }
+miniz_oxide = { version = "0.4.0", optional = true, default-features = false }
+[dependencies.object]
+version = "0.26.1"
+optional = true
+default-features = false
+features = ['read_core', 'elf', 'macho', 'pe', 'unaligned', 'archive']
+
+[dev-dependencies]
+rand = "0.7"
+
+[target.'cfg(any(all(target_family = "wasm", not(target_os = "emscripten")), all(target_vendor = "fortanix", target_env = "sgx")))'.dependencies]
+dlmalloc = { version = "0.2.3", features = ['rustc-dep-of-std'] }
+
+[target.x86_64-fortanix-unknown-sgx.dependencies]
+fortanix-sgx-abi = { version = "0.3.2", features = ['rustc-dep-of-std'] }
+
+[target.'cfg(target_os = "hermit")'.dependencies]
+hermit-abi = { version = "0.2.0", features = ['rustc-dep-of-std'] }
+
+[target.wasm32-wasi.dependencies]
+wasi = { version = "0.11.0", features = ['rustc-dep-of-std'], default-features = false }
+
+[features]
+backtrace = [
+ "gimli-symbolize",
+ 'addr2line/rustc-dep-of-std',
+ 'object/rustc-dep-of-std',
+ 'miniz_oxide/rustc-dep-of-std',
+]
+gimli-symbolize = []
+
+panic-unwind = ["panic_unwind"]
+profiler = ["profiler_builtins"]
+compiler-builtins-c = ["alloc/compiler-builtins-c"]
+compiler-builtins-mem = ["alloc/compiler-builtins-mem"]
+compiler-builtins-no-asm = ["alloc/compiler-builtins-no-asm"]
+compiler-builtins-mangled-names = ["alloc/compiler-builtins-mangled-names"]
+llvm-libunwind = ["unwind/llvm-libunwind"]
+system-llvm-libunwind = ["unwind/system-llvm-libunwind"]
+
+# Make panics and failed asserts immediately abort without formatting any message
+panic_immediate_abort = ["core/panic_immediate_abort"]
+
+# Enable std_detect default features for stdarch/crates/std_detect:
+# https://github.com/rust-lang/stdarch/blob/master/crates/std_detect/Cargo.toml
+std_detect_file_io = ["std_detect/std_detect_file_io"]
+std_detect_dlsym_getauxval = ["std_detect/std_detect_dlsym_getauxval"]
+std_detect_env_override = ["std_detect/std_detect_env_override"]
+
+[package.metadata.fortanix-sgx]
+# Maximum possible number of threads when testing
+threads = 125
+# Maximum heap size
+heap_size = 0x8000000
+
+[[bench]]
+name = "stdbenches"
+path = "benches/lib.rs"
+test = true