summaryrefslogtreecommitdiffstats
path: root/library/stdarch/crates/stdarch-gen/README.md
diff options
context:
space:
mode:
Diffstat (limited to 'library/stdarch/crates/stdarch-gen/README.md')
-rw-r--r--library/stdarch/crates/stdarch-gen/README.md11
1 files changed, 11 insertions, 0 deletions
diff --git a/library/stdarch/crates/stdarch-gen/README.md b/library/stdarch/crates/stdarch-gen/README.md
new file mode 100644
index 000000000..54b602cdd
--- /dev/null
+++ b/library/stdarch/crates/stdarch-gen/README.md
@@ -0,0 +1,11 @@
+# Neon intrinsic code generator
+
+A small tool that allows to quickly generate intrinsics for the NEON architecture.
+
+The specification for the intrinsics can be found in `neon.spec`.
+
+To run and re-generate the code run the following from the root of the `stdarch` crate.
+
+```
+OUT_DIR=`pwd`/crates/core_arch cargo run -p stdarch-gen -- crates/stdarch-gen/neon.spec
+``` \ No newline at end of file