summaryrefslogtreecommitdiffstats
path: root/library/stdarch/examples
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--library/stdarch/examples/Cargo.toml2
-rw-r--r--library/stdarch/examples/connect5.rs2
-rw-r--r--library/stdarch/examples/hex.rs2
3 files changed, 3 insertions, 3 deletions
diff --git a/library/stdarch/examples/Cargo.toml b/library/stdarch/examples/Cargo.toml
index e2590ed9f..38f497fa6 100644
--- a/library/stdarch/examples/Cargo.toml
+++ b/library/stdarch/examples/Cargo.toml
@@ -7,7 +7,7 @@ authors = [
"Gonzalo Brito Gadeschi <gonzalobg88@gmail.com>",
]
description = "Examples of the stdarch crate."
-edition = "2018"
+edition = "2021"
default-run = "hex"
[dependencies]
diff --git a/library/stdarch/examples/connect5.rs b/library/stdarch/examples/connect5.rs
index 1b3325785..09e7e48a7 100644
--- a/library/stdarch/examples/connect5.rs
+++ b/library/stdarch/examples/connect5.rs
@@ -1256,7 +1256,7 @@ fn main() {
pos_disp(&test1);
if pos_is_end(&test1) {
- println!("Game over!!!!!! at Move {}", i);
+ println!("Game over!!!!!! at Move {i}");
count = i + 1;
break;
}
diff --git a/library/stdarch/examples/hex.rs b/library/stdarch/examples/hex.rs
index d982a71b9..a961793a0 100644
--- a/library/stdarch/examples/hex.rs
+++ b/library/stdarch/examples/hex.rs
@@ -40,7 +40,7 @@ fn main() {
io::stdin().read_to_end(&mut input).unwrap();
let mut dst = vec![0; 2 * input.len()];
let s = hex_encode(&input, &mut dst).unwrap();
- println!("{}", s);
+ println!("{s}");
}
fn hex_encode<'a>(src: &[u8], dst: &'a mut [u8]) -> Result<&'a str, usize> {