summaryrefslogtreecommitdiffstats
path: root/library/unwind/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'library/unwind/Cargo.toml')
-rw-r--r--library/unwind/Cargo.toml34
1 files changed, 34 insertions, 0 deletions
diff --git a/library/unwind/Cargo.toml b/library/unwind/Cargo.toml
new file mode 100644
index 000000000..69fce8d77
--- /dev/null
+++ b/library/unwind/Cargo.toml
@@ -0,0 +1,34 @@
+[package]
+name = "unwind"
+version = "0.0.0"
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/rust-lang/rust.git"
+edition = "2021"
+include = [
+ '/libunwind/*',
+]
+
+[lib]
+test = false
+bench = false
+doc = false
+
+[dependencies]
+core = { path = "../core" }
+libc = { version = "0.2.79", features = ['rustc-dep-of-std'], default-features = false }
+compiler_builtins = "0.1.0"
+cfg-if = "0.1.8"
+
+[build-dependencies]
+cc = "1.0.69"
+
+[features]
+
+# Only applies for Linux and Fuchsia targets
+# Static link to the in-tree build of llvm libunwind
+llvm-libunwind = []
+
+# Only applies for Linux and Fuchsia targets
+# If crt-static is enabled, static link to `libunwind.a` provided by system
+# If crt-static is disabled, dynamic link to `libunwind.so` provided by system
+system-llvm-libunwind = []