summaryrefslogtreecommitdiffstats
path: root/src/bootstrap/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'src/bootstrap/Cargo.toml')
-rw-r--r--src/bootstrap/Cargo.toml39
1 files changed, 20 insertions, 19 deletions
diff --git a/src/bootstrap/Cargo.toml b/src/bootstrap/Cargo.toml
index 9bf26948a..e4d359141 100644
--- a/src/bootstrap/Cargo.toml
+++ b/src/bootstrap/Cargo.toml
@@ -5,38 +5,48 @@ edition = "2021"
build = "build.rs"
default-run = "bootstrap"
+[features]
+build-metrics = ["sysinfo"]
+
[lib]
-path = "lib.rs"
+path = "src/lib.rs"
doctest = false
[[bin]]
name = "bootstrap"
-path = "bin/main.rs"
+path = "src/bin/main.rs"
test = false
[[bin]]
name = "rustc"
-path = "bin/rustc.rs"
+path = "src/bin/rustc.rs"
test = false
[[bin]]
name = "rustdoc"
-path = "bin/rustdoc.rs"
+path = "src/bin/rustdoc.rs"
test = false
[[bin]]
name = "sccache-plus-cl"
-path = "bin/sccache-plus-cl.rs"
+path = "src/bin/sccache-plus-cl.rs"
test = false
[dependencies]
build_helper = { path = "../tools/build_helper" }
+cc = "1.0.69"
+clap = { version = "4.4.7", default-features = false, features = ["std", "usage", "help", "derive", "error-context"] }
+clap_complete = "4.4.3"
cmake = "0.1.38"
filetime = "0.2"
-cc = "1.0.69"
-libc = "0.2"
hex = "0.4"
+home = "0.5.4"
+ignore = "0.4.10"
+libc = "0.2"
object = { version = "0.32.0", default-features = false, features = ["archive", "coff", "read_core", "unaligned"] }
+once_cell = "1.7.2"
+opener = "0.5"
+semver = "1.0.17"
serde = "1.0.137"
# Directly use serde_derive rather than through the derive feature of serde to allow building both
# in parallel and to allow serde_json and toml to start building as soon as serde has been built.
@@ -46,27 +56,21 @@ sha2 = "0.10"
tar = "0.4"
termcolor = "1.2.0"
toml = "0.5"
-ignore = "0.4.10"
-opener = "0.5"
-once_cell = "1.7.2"
-xz2 = "0.1"
walkdir = "2"
+xz2 = "0.1"
# Dependencies needed by the build-metrics feature
sysinfo = { version = "0.26.0", optional = true }
-clap = { version = "4.2.4", default-features = false, features = ["std", "usage", "help", "derive", "error-context"] }
-clap_complete = "4.2.2"
-semver = "1.0.17"
# Solaris doesn't support flock() and thus fd-lock is not option now
[target.'cfg(not(target_os = "solaris"))'.dependencies]
-fd-lock = "3.0.8"
+fd-lock = "3.0.13"
[target.'cfg(windows)'.dependencies.junction]
version = "1.0.0"
[target.'cfg(windows)'.dependencies.windows]
-version = "0.46.0"
+version = "0.51.1"
features = [
"Win32_Foundation",
"Win32_Security",
@@ -80,9 +84,6 @@ features = [
[dev-dependencies]
pretty_assertions = "1.4"
-[features]
-build-metrics = ["sysinfo"]
-
# We care a lot about bootstrap's compile times, so don't include debuginfo for
# dependencies, only bootstrap itself.
[profile.dev]