summaryrefslogtreecommitdiffstats
path: root/src/bootstrap/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'src/bootstrap/Cargo.toml')
-rw-r--r--src/bootstrap/Cargo.toml85
1 files changed, 85 insertions, 0 deletions
diff --git a/src/bootstrap/Cargo.toml b/src/bootstrap/Cargo.toml
new file mode 100644
index 000000000..84f6aaf99
--- /dev/null
+++ b/src/bootstrap/Cargo.toml
@@ -0,0 +1,85 @@
+[package]
+name = "bootstrap"
+version = "0.0.0"
+edition = "2021"
+build = "build.rs"
+default-run = "bootstrap"
+
+[lib]
+path = "lib.rs"
+doctest = false
+
+[[bin]]
+name = "bootstrap"
+path = "bin/main.rs"
+test = false
+
+[[bin]]
+name = "rustc"
+path = "bin/rustc.rs"
+test = false
+
+[[bin]]
+name = "rustdoc"
+path = "bin/rustdoc.rs"
+test = false
+
+[[bin]]
+name = "sccache-plus-cl"
+path = "bin/sccache-plus-cl.rs"
+test = false
+
+[[bin]]
+name = "llvm-config-wrapper"
+path = "bin/llvm-config-wrapper.rs"
+test = false
+
+[dependencies]
+cmake = "0.1.38"
+fd-lock = "3.0.6"
+filetime = "0.2"
+num_cpus = "1.0"
+getopts = "0.2.19"
+cc = "1.0.69"
+libc = "0.2"
+hex = "0.4"
+serde = { version = "1.0.8", features = ["derive"] }
+serde_json = "1.0.2"
+sha2 = "0.10"
+tar = "0.4"
+toml = "0.5"
+ignore = "0.4.10"
+opener = "0.5"
+once_cell = "1.7.2"
+xz2 = "0.1"
+walkdir = "2"
+
+# Dependencies needed by the build-metrics feature
+sysinfo = { version = "0.24.1", optional = true }
+
+[target.'cfg(windows)'.dependencies.winapi]
+version = "0.3"
+features = [
+ "fileapi",
+ "ioapiset",
+ "jobapi2",
+ "handleapi",
+ "winioctl",
+ "psapi",
+ "impl-default",
+ "timezoneapi",
+]
+
+[dev-dependencies]
+pretty_assertions = "0.7"
+
+[features]
+build-metrics = ["sysinfo"]
+
+# We care a lot about bootstrap's compile times, so don't include debuginfo for
+# dependencies, only bootstrap itself.
+[profile.dev]
+debug = 0
+[profile.dev.package]
+# Only use debuginfo=1 to further reduce compile times.
+bootstrap.debug = 1