summaryrefslogtreecommitdiffstats
path: root/src/bootstrap/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'src/bootstrap/Cargo.toml')
-rw-r--r--src/bootstrap/Cargo.toml11
1 files changed, 5 insertions, 6 deletions
diff --git a/src/bootstrap/Cargo.toml b/src/bootstrap/Cargo.toml
index eeda6d7c1..367c61909 100644
--- a/src/bootstrap/Cargo.toml
+++ b/src/bootstrap/Cargo.toml
@@ -34,11 +34,10 @@ is-terminal = "0.4"
build_helper = { path = "../tools/build_helper" }
cmake = "0.1.38"
filetime = "0.2"
-getopts = "0.2.19"
cc = "1.0.69"
libc = "0.2"
hex = "0.4"
-object = { version = "0.29.0", default-features = false, features = ["archive", "coff", "read_core", "unaligned"] }
+object = { version = "0.31.1", default-features = false, features = ["archive", "coff", "read_core", "unaligned"] }
serde = "1.0.137"
# Directly use serde_derive rather than through the derive feature of serde to allow building both
# in parallel and to allow serde_json and toml to start building as soon as serde has been built.
@@ -56,6 +55,9 @@ walkdir = "2"
# Dependencies needed by the build-metrics feature
sysinfo = { version = "0.26.0", optional = true }
+clap = { version = "4.2.4", default-features = false, features = ["std", "usage", "help", "derive", "error-context"] }
+clap_complete = "4.2.2"
+semver = "1.0.17"
# Solaris doesn't support flock() and thus fd-lock is not option now
[target.'cfg(not(target_os = "solaris"))'.dependencies]
@@ -69,13 +71,9 @@ version = "0.46.0"
features = [
"Win32_Foundation",
"Win32_Security",
- "Win32_Storage_FileSystem",
"Win32_System_Diagnostics_Debug",
- "Win32_System_IO",
- "Win32_System_Ioctl",
"Win32_System_JobObjects",
"Win32_System_ProcessStatus",
- "Win32_System_SystemServices",
"Win32_System_Threading",
"Win32_System_Time",
]
@@ -90,6 +88,7 @@ build-metrics = ["sysinfo"]
# dependencies, only bootstrap itself.
[profile.dev]
debug = 0
+
[profile.dev.package]
# Only use debuginfo=1 to further reduce compile times.
bootstrap.debug = 1