summaryrefslogtreecommitdiffstats
path: root/src/bootstrap/dist.rs
diff options
context:
space:
mode:
Diffstat (limited to 'src/bootstrap/dist.rs')
-rw-r--r--src/bootstrap/dist.rs19
1 files changed, 5 insertions, 14 deletions
diff --git a/src/bootstrap/dist.rs b/src/bootstrap/dist.rs
index 76aad16c1..9cead7adc 100644
--- a/src/bootstrap/dist.rs
+++ b/src/bootstrap/dist.rs
@@ -822,6 +822,8 @@ fn copy_src_dirs(
"llvm-project\\compiler-rt",
"llvm-project/cmake",
"llvm-project\\cmake",
+ "llvm-project/runtimes",
+ "llvm-project\\runtimes",
];
if spath.contains("llvm-project")
&& !spath.ends_with("llvm-project")
@@ -997,12 +999,15 @@ impl Step for PlainSourceTarball {
// If we're building from git sources, we need to vendor a complete distribution.
if builder.rust_info().is_managed_git_subrepository() {
// Ensure we have the submodules checked out.
+ builder.update_submodule(Path::new("src/tools/cargo"));
builder.update_submodule(Path::new("src/tools/rust-analyzer"));
// Vendor all Cargo dependencies
let mut cmd = Command::new(&builder.initial_cargo);
cmd.arg("vendor")
.arg("--sync")
+ .arg(builder.src.join("./src/tools/cargo/Cargo.toml"))
+ .arg("--sync")
.arg(builder.src.join("./src/tools/rust-analyzer/Cargo.toml"))
.arg("--sync")
.arg(builder.src.join("./compiler/rustc_codegen_cranelift/Cargo.toml"))
@@ -1963,20 +1968,6 @@ fn maybe_install_llvm(builder: &Builder<'_>, target: TargetSelection, dst_libdir
}
}
- // FIXME: for reasons I don't understand, the LLVM so in the `rustc` component is different than the one in `rust-dev`.
- // Only the one in `rustc` works with the downloaded compiler.
- if builder.download_rustc() && target == builder.build.build {
- let src_libdir = builder.ci_rustc_dir(target).join("lib");
- for entry in t!(std::fs::read_dir(&src_libdir)) {
- let entry = t!(entry);
- if entry.file_name().to_str().unwrap().starts_with("libLLVM-") {
- install_llvm_file(builder, &entry.path(), dst_libdir);
- return !builder.config.dry_run();
- }
- }
- panic!("libLLVM.so not found in src_libdir {}!", src_libdir.display());
- }
-
// On macOS, rustc (and LLVM tools) link to an unversioned libLLVM.dylib
// instead of libLLVM-11-rust-....dylib, as on linux. It's not entirely
// clear why this is the case, though. llvm-config will emit the versioned