summaryrefslogtreecommitdiffstats
path: root/src/doc/book/listings/ch06-enums-and-pattern-matching/listing-06-06
diff options
context:
space:
mode:
Diffstat (limited to 'src/doc/book/listings/ch06-enums-and-pattern-matching/listing-06-06')
-rw-r--r--src/doc/book/listings/ch06-enums-and-pattern-matching/listing-06-06/Cargo.lock6
-rw-r--r--src/doc/book/listings/ch06-enums-and-pattern-matching/listing-06-06/Cargo.toml6
-rw-r--r--src/doc/book/listings/ch06-enums-and-pattern-matching/listing-06-06/src/main.rs9
3 files changed, 21 insertions, 0 deletions
diff --git a/src/doc/book/listings/ch06-enums-and-pattern-matching/listing-06-06/Cargo.lock b/src/doc/book/listings/ch06-enums-and-pattern-matching/listing-06-06/Cargo.lock
new file mode 100644
index 000000000..f62e8ac45
--- /dev/null
+++ b/src/doc/book/listings/ch06-enums-and-pattern-matching/listing-06-06/Cargo.lock
@@ -0,0 +1,6 @@
+# This file is automatically @generated by Cargo.
+# It is not intended for manual editing.
+[[package]]
+name = "enums"
+version = "0.1.0"
+
diff --git a/src/doc/book/listings/ch06-enums-and-pattern-matching/listing-06-06/Cargo.toml b/src/doc/book/listings/ch06-enums-and-pattern-matching/listing-06-06/Cargo.toml
new file mode 100644
index 000000000..e959295f9
--- /dev/null
+++ b/src/doc/book/listings/ch06-enums-and-pattern-matching/listing-06-06/Cargo.toml
@@ -0,0 +1,6 @@
+[package]
+name = "enums"
+version = "0.1.0"
+edition = "2021"
+
+[dependencies]
diff --git a/src/doc/book/listings/ch06-enums-and-pattern-matching/listing-06-06/src/main.rs b/src/doc/book/listings/ch06-enums-and-pattern-matching/listing-06-06/src/main.rs
new file mode 100644
index 000000000..dc2bffb91
--- /dev/null
+++ b/src/doc/book/listings/ch06-enums-and-pattern-matching/listing-06-06/src/main.rs
@@ -0,0 +1,9 @@
+fn main() {
+ // ANCHOR: here
+ let config_max = Some(3u8);
+ match config_max {
+ Some(max) => println!("The maximum is configured to be {}", max),
+ _ => (),
+ }
+ // ANCHOR_END: here
+}