summaryrefslogtreecommitdiffstats
path: root/src/doc/book/listings/ch08-common-collections/listing-08-14
diff options
context:
space:
mode:
Diffstat (limited to 'src/doc/book/listings/ch08-common-collections/listing-08-14')
-rw-r--r--src/doc/book/listings/ch08-common-collections/listing-08-14/Cargo.lock6
-rw-r--r--src/doc/book/listings/ch08-common-collections/listing-08-14/Cargo.toml6
-rw-r--r--src/doc/book/listings/ch08-common-collections/listing-08-14/src/main.rs19
3 files changed, 31 insertions, 0 deletions
diff --git a/src/doc/book/listings/ch08-common-collections/listing-08-14/Cargo.lock b/src/doc/book/listings/ch08-common-collections/listing-08-14/Cargo.lock
new file mode 100644
index 000000000..d3daeff7d
--- /dev/null
+++ b/src/doc/book/listings/ch08-common-collections/listing-08-14/Cargo.lock
@@ -0,0 +1,6 @@
+# This file is automatically @generated by Cargo.
+# It is not intended for manual editing.
+[[package]]
+name = "collections"
+version = "0.1.0"
+
diff --git a/src/doc/book/listings/ch08-common-collections/listing-08-14/Cargo.toml b/src/doc/book/listings/ch08-common-collections/listing-08-14/Cargo.toml
new file mode 100644
index 000000000..fe4959823
--- /dev/null
+++ b/src/doc/book/listings/ch08-common-collections/listing-08-14/Cargo.toml
@@ -0,0 +1,6 @@
+[package]
+name = "collections"
+version = "0.1.0"
+edition = "2021"
+
+[dependencies]
diff --git a/src/doc/book/listings/ch08-common-collections/listing-08-14/src/main.rs b/src/doc/book/listings/ch08-common-collections/listing-08-14/src/main.rs
new file mode 100644
index 000000000..f701fd578
--- /dev/null
+++ b/src/doc/book/listings/ch08-common-collections/listing-08-14/src/main.rs
@@ -0,0 +1,19 @@
+fn main() {
+ // ANCHOR: here
+ let hello = String::from("السلام عليكم");
+ let hello = String::from("Dobrý den");
+ let hello = String::from("Hello");
+ let hello = String::from("שָׁלוֹם");
+ let hello = String::from("नमस्ते");
+ let hello = String::from("こんにちは");
+ let hello = String::from("안녕하세요");
+ let hello = String::from("你好");
+ let hello = String::from("Olá");
+ // ANCHOR: russian
+ let hello = String::from("Здравствуйте");
+ // ANCHOR_END: russian
+ // ANCHOR: spanish
+ let hello = String::from("Hola");
+ // ANCHOR_END: spanish
+ // ANCHOR_END: here
+}