summaryrefslogtreecommitdiffstats
path: root/src/doc/book/listings/ch08-common-collections/listing-08-19
diff options
context:
space:
mode:
Diffstat (limited to 'src/doc/book/listings/ch08-common-collections/listing-08-19')
-rw-r--r--src/doc/book/listings/ch08-common-collections/listing-08-19/Cargo.lock6
-rw-r--r--src/doc/book/listings/ch08-common-collections/listing-08-19/Cargo.toml6
-rw-r--r--src/doc/book/listings/ch08-common-collections/listing-08-19/output.txt20
-rw-r--r--src/doc/book/listings/ch08-common-collections/listing-08-19/src/main.rs6
4 files changed, 38 insertions, 0 deletions
diff --git a/src/doc/book/listings/ch08-common-collections/listing-08-19/Cargo.lock b/src/doc/book/listings/ch08-common-collections/listing-08-19/Cargo.lock
new file mode 100644
index 000000000..d3daeff7d
--- /dev/null
+++ b/src/doc/book/listings/ch08-common-collections/listing-08-19/Cargo.lock
@@ -0,0 +1,6 @@
+# This file is automatically @generated by Cargo.
+# It is not intended for manual editing.
+[[package]]
+name = "collections"
+version = "0.1.0"
+
diff --git a/src/doc/book/listings/ch08-common-collections/listing-08-19/Cargo.toml b/src/doc/book/listings/ch08-common-collections/listing-08-19/Cargo.toml
new file mode 100644
index 000000000..fe4959823
--- /dev/null
+++ b/src/doc/book/listings/ch08-common-collections/listing-08-19/Cargo.toml
@@ -0,0 +1,6 @@
+[package]
+name = "collections"
+version = "0.1.0"
+edition = "2021"
+
+[dependencies]
diff --git a/src/doc/book/listings/ch08-common-collections/listing-08-19/output.txt b/src/doc/book/listings/ch08-common-collections/listing-08-19/output.txt
new file mode 100644
index 000000000..95577772e
--- /dev/null
+++ b/src/doc/book/listings/ch08-common-collections/listing-08-19/output.txt
@@ -0,0 +1,20 @@
+$ cargo run
+ Compiling collections v0.1.0 (file:///projects/collections)
+error[E0277]: the type `String` cannot be indexed by `{integer}`
+ --> src/main.rs:3:13
+ |
+3 | let h = s1[0];
+ | ^^^^^ `String` cannot be indexed by `{integer}`
+ |
+ = help: the trait `Index<{integer}>` is not implemented for `String`
+ = help: the following other types implement trait `Index<Idx>`:
+ <String as Index<RangeFrom<usize>>>
+ <String as Index<RangeFull>>
+ <String as Index<RangeInclusive<usize>>>
+ <String as Index<RangeTo<usize>>>
+ <String as Index<RangeToInclusive<usize>>>
+ <String as Index<std::ops::Range<usize>>>
+ <str as Index<I>>
+
+For more information about this error, try `rustc --explain E0277`.
+error: could not compile `collections` due to previous error
diff --git a/src/doc/book/listings/ch08-common-collections/listing-08-19/src/main.rs b/src/doc/book/listings/ch08-common-collections/listing-08-19/src/main.rs
new file mode 100644
index 000000000..fc08e9cea
--- /dev/null
+++ b/src/doc/book/listings/ch08-common-collections/listing-08-19/src/main.rs
@@ -0,0 +1,6 @@
+fn main() {
+ // ANCHOR: here
+ let s1 = String::from("hello");
+ let h = s1[0];
+ // ANCHOR_END: here
+}