summaryrefslogtreecommitdiffstats
path: root/src/doc/book/listings/ch12-an-io-project/listing-12-05
diff options
context:
space:
mode:
Diffstat (limited to 'src/doc/book/listings/ch12-an-io-project/listing-12-05')
-rw-r--r--src/doc/book/listings/ch12-an-io-project/listing-12-05/Cargo.lock6
-rw-r--r--src/doc/book/listings/ch12-an-io-project/listing-12-05/Cargo.toml6
-rw-r--r--src/doc/book/listings/ch12-an-io-project/listing-12-05/poem.txt9
-rw-r--r--src/doc/book/listings/ch12-an-io-project/listing-12-05/src/main.rs29
4 files changed, 50 insertions, 0 deletions
diff --git a/src/doc/book/listings/ch12-an-io-project/listing-12-05/Cargo.lock b/src/doc/book/listings/ch12-an-io-project/listing-12-05/Cargo.lock
new file mode 100644
index 000000000..88bf82d16
--- /dev/null
+++ b/src/doc/book/listings/ch12-an-io-project/listing-12-05/Cargo.lock
@@ -0,0 +1,6 @@
+# This file is automatically @generated by Cargo.
+# It is not intended for manual editing.
+[[package]]
+name = "minigrep"
+version = "0.1.0"
+
diff --git a/src/doc/book/listings/ch12-an-io-project/listing-12-05/Cargo.toml b/src/doc/book/listings/ch12-an-io-project/listing-12-05/Cargo.toml
new file mode 100644
index 000000000..64c2a3f52
--- /dev/null
+++ b/src/doc/book/listings/ch12-an-io-project/listing-12-05/Cargo.toml
@@ -0,0 +1,6 @@
+[package]
+name = "minigrep"
+version = "0.1.0"
+edition = "2021"
+
+[dependencies]
diff --git a/src/doc/book/listings/ch12-an-io-project/listing-12-05/poem.txt b/src/doc/book/listings/ch12-an-io-project/listing-12-05/poem.txt
new file mode 100644
index 000000000..870752731
--- /dev/null
+++ b/src/doc/book/listings/ch12-an-io-project/listing-12-05/poem.txt
@@ -0,0 +1,9 @@
+I'm nobody! Who are you?
+Are you nobody, too?
+Then there's a pair of us - don't tell!
+They'd banish us, you know.
+
+How dreary to be somebody!
+How public, like a frog
+To tell your name the livelong day
+To an admiring bog!
diff --git a/src/doc/book/listings/ch12-an-io-project/listing-12-05/src/main.rs b/src/doc/book/listings/ch12-an-io-project/listing-12-05/src/main.rs
new file mode 100644
index 000000000..061591833
--- /dev/null
+++ b/src/doc/book/listings/ch12-an-io-project/listing-12-05/src/main.rs
@@ -0,0 +1,29 @@
+use std::env;
+use std::fs;
+
+// ANCHOR: here
+fn main() {
+ let args: Vec<String> = env::args().collect();
+
+ let (query, file_path) = parse_config(&args);
+
+ // --snip--
+ // ANCHOR_END: here
+
+ println!("Searching for {}", query);
+ println!("In file {}", file_path);
+
+ let contents = fs::read_to_string(file_path)
+ .expect("Should have been able to read the file");
+
+ println!("With text:\n{contents}");
+ // ANCHOR: here
+}
+
+fn parse_config(args: &[String]) -> (&str, &str) {
+ let query = &args[1];
+ let file_path = &args[2];
+
+ (query, file_path)
+}
+// ANCHOR_END: here