summaryrefslogtreecommitdiffstats
path: root/src/etc/rust_analyzer_settings.json
diff options
context:
space:
mode:
Diffstat (limited to 'src/etc/rust_analyzer_settings.json')
-rw-r--r--src/etc/rust_analyzer_settings.json9
1 files changed, 8 insertions, 1 deletions
diff --git a/src/etc/rust_analyzer_settings.json b/src/etc/rust_analyzer_settings.json
index dd01bfaa7..d9c4645f0 100644
--- a/src/etc/rust_analyzer_settings.json
+++ b/src/etc/rust_analyzer_settings.json
@@ -7,7 +7,14 @@
"check",
"--json-output"
],
- "rust-analyzer.linkedProjects": ["src/bootstrap/Cargo.toml", "Cargo.toml"],
+ "rust-analyzer.linkedProjects": [
+ "Cargo.toml",
+ "src/tools/x/Cargo.toml",
+ "src/bootstrap/Cargo.toml",
+ "src/tools/rust-analyzer/Cargo.toml",
+ "compiler/rustc_codegen_cranelift/Cargo.toml",
+ "compiler/rustc_codegen_gcc/Cargo.toml"
+ ],
"rust-analyzer.rustfmt.overrideCommand": [
"./build/host/rustfmt/bin/rustfmt",
"--edition=2021"