summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/glibc-staticlib-args/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/run-make-fulldeps/glibc-staticlib-args/Makefile')
-rw-r--r--src/test/run-make-fulldeps/glibc-staticlib-args/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/test/run-make-fulldeps/glibc-staticlib-args/Makefile b/src/test/run-make-fulldeps/glibc-staticlib-args/Makefile
new file mode 100644
index 000000000..ad841ec61
--- /dev/null
+++ b/src/test/run-make-fulldeps/glibc-staticlib-args/Makefile
@@ -0,0 +1,12 @@
+# only-gnu
+# only-linux
+
+-include ../tools.mk
+
+# This ensures that std::env::args works in a library called from C on glibc Linux.
+
+all:
+ $(RUSTC) --crate-type=staticlib library.rs
+ $(CC) program.c $(call STATICLIB,library) $(call OUT_EXE,program) \
+ $(EXTRACFLAGS) $(EXTRACXXFLAGS)
+ $(call RUN,program)