summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/lto-dylib-dep/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/run-make-fulldeps/lto-dylib-dep/Makefile')
-rw-r--r--src/test/run-make-fulldeps/lto-dylib-dep/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/test/run-make-fulldeps/lto-dylib-dep/Makefile b/src/test/run-make-fulldeps/lto-dylib-dep/Makefile
new file mode 100644
index 000000000..ab8ee6c2e
--- /dev/null
+++ b/src/test/run-make-fulldeps/lto-dylib-dep/Makefile
@@ -0,0 +1,10 @@
+-include ../tools.mk
+
+# Test that we don't run into an assertion when using a Rust dylib dependency
+# while compiling with full LTO.
+# See https://github.com/rust-lang/rust/issues/59137
+
+all:
+ $(RUSTC) a_dylib.rs --crate-type=dylib -C prefer-dynamic
+ $(RUSTC) main.rs -C lto
+ $(call RUN,main)