summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/lto-empty/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/run-make-fulldeps/lto-empty/Makefile')
-rw-r--r--src/test/run-make-fulldeps/lto-empty/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/test/run-make-fulldeps/lto-empty/Makefile b/src/test/run-make-fulldeps/lto-empty/Makefile
new file mode 100644
index 000000000..345d10bc4
--- /dev/null
+++ b/src/test/run-make-fulldeps/lto-empty/Makefile
@@ -0,0 +1,12 @@
+-include ../tools.mk
+
+all: cdylib-fat cdylib-thin
+
+cdylib-fat:
+ $(RUSTC) lib.rs -C lto=fat -C opt-level=3 -C incremental=$(TMPDIR)/inc-fat
+ $(RUSTC) lib.rs -C lto=fat -C opt-level=3 -C incremental=$(TMPDIR)/inc-fat
+
+cdylib-thin:
+ $(RUSTC) lib.rs -C lto=thin -C opt-level=3 -C incremental=$(TMPDIR)/inc-thin
+ $(RUSTC) lib.rs -C lto=thin -C opt-level=3 -C incremental=$(TMPDIR)/inc-thin
+