summaryrefslogtreecommitdiffstats
path: root/src/test/run-make/pass-linker-flags-from-dep/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/run-make/pass-linker-flags-from-dep/Makefile')
-rw-r--r--src/test/run-make/pass-linker-flags-from-dep/Makefile10
1 files changed, 0 insertions, 10 deletions
diff --git a/src/test/run-make/pass-linker-flags-from-dep/Makefile b/src/test/run-make/pass-linker-flags-from-dep/Makefile
deleted file mode 100644
index b9426326a..000000000
--- a/src/test/run-make/pass-linker-flags-from-dep/Makefile
+++ /dev/null
@@ -1,10 +0,0 @@
-include ../../run-make-fulldeps/tools.mk
-
-all:
- # Build deps
- $(RUSTC) native_dep_1.rs --crate-type=staticlib
- $(RUSTC) native_dep_2.rs --crate-type=staticlib
- $(RUSTC) rust_dep.rs -l static:-bundle=native_dep_1 -l link-arg=some_flag -l static:-bundle=native_dep_2 --crate-type=lib -Z unstable-options
-
- # Check sequence of linker args
- $(RUSTC) main.rs --extern lib=$(TMPDIR)/librust_dep.rlib --crate-type=bin --print link-args | $(CGREP) -e 'native_dep_1.*some_flag.*native_dep_2'