summaryrefslogtreecommitdiffstats
path: root/src/test/run-make/rustc-macro-dep-files
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/run-make/rustc-macro-dep-files')
-rw-r--r--src/test/run-make/rustc-macro-dep-files/Makefile11
-rw-r--r--src/test/run-make/rustc-macro-dep-files/bar.rs8
-rw-r--r--src/test/run-make/rustc-macro-dep-files/foo.rs12
3 files changed, 31 insertions, 0 deletions
diff --git a/src/test/run-make/rustc-macro-dep-files/Makefile b/src/test/run-make/rustc-macro-dep-files/Makefile
new file mode 100644
index 000000000..a08a63fb4
--- /dev/null
+++ b/src/test/run-make/rustc-macro-dep-files/Makefile
@@ -0,0 +1,11 @@
+-include ../../run-make-fulldeps/tools.mk
+
+# FIXME(eddyb) provide `HOST_RUSTC` and `TARGET_RUSTC`
+# instead of hardcoding them everywhere they're needed.
+ifeq ($(IS_MUSL_HOST),1)
+ADDITIONAL_ARGS := $(RUSTFLAGS)
+endif
+all:
+ $(BARE_RUSTC) $(ADDITIONAL_ARGS) foo.rs --out-dir $(TMPDIR)
+ $(RUSTC) bar.rs --target $(TARGET) --emit dep-info
+ $(CGREP) -v "proc-macro source" < $(TMPDIR)/bar.d
diff --git a/src/test/run-make/rustc-macro-dep-files/bar.rs b/src/test/run-make/rustc-macro-dep-files/bar.rs
new file mode 100644
index 000000000..4a3b3364b
--- /dev/null
+++ b/src/test/run-make/rustc-macro-dep-files/bar.rs
@@ -0,0 +1,8 @@
+#![no_std]
+#![crate_type = "lib"]
+
+#[macro_use]
+extern crate foo;
+
+#[derive(A)]
+struct A;
diff --git a/src/test/run-make/rustc-macro-dep-files/foo.rs b/src/test/run-make/rustc-macro-dep-files/foo.rs
new file mode 100644
index 000000000..66db1a217
--- /dev/null
+++ b/src/test/run-make/rustc-macro-dep-files/foo.rs
@@ -0,0 +1,12 @@
+#![crate_type = "proc-macro"]
+
+extern crate proc_macro;
+
+use proc_macro::TokenStream;
+
+#[proc_macro_derive(A)]
+pub fn derive(input: TokenStream) -> TokenStream {
+ let input = input.to_string();
+ assert!(input.contains("struct A ;"));
+ "struct B;".parse().unwrap()
+}